Bug #85711 Bug while installing connector/net
Submitted: 30 Mar 2017 14:29 Modified: 4 Apr 2017 20:18
Reporter: Farah Hussein Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.9.9 OS:Microsoft Windows (windows 7 64bit)
Assigned to: CPU Architecture:Any

[30 Mar 2017 14:29] Farah Hussein
Description:
while trying to updated using mysql installer i got this error attached. And i tried to use the installer still it will stop and it start roll back and fail the installer.

How to repeat:
1: Action 10:22:05: INSTALL. 
1: 1: MySQL Connector Net 6.9.9 2: {E09F82E9-3EB3-4725-BDC8-3C77F83E262C} 
1: Action 10:22:05: FindRelatedProducts. Searching for related applications
1: Action 10:22:05: AppSearch. Searching for installed applications
1: Action 10:22:05: LaunchConditions. Evaluating launch conditions
1: Action 10:22:05: ValidateProductID. 
1: Action 10:22:05: CostInitialize. Computing space requirements
1: Action 10:22:05: FileCost. Computing space requirements
1: Action 10:22:05: CostFinalize. Computing space requirements
1: Action 10:22:05: InstallValidate. Validating install
1: Action 10:22:05: Setv4InstallUtil. 
1: Action 10:22:06: InstallInitialize. 
1: Action 10:22:06: RemoveExistingProducts. Removing applications
1: Application: {2C148B86-FF80-49A7-BA18-E4CEF6464AE6}, Command line: UPGRADINGPRODUCTCODE={E09F82E9-3EB3-4725-BDC8-3C77F83E262C}  CLIENTUILEVEL=3 REMOVE=ALL
1: Action 10:22:06: INSTALL. 
1: 1: MySQL Connector Net 6.9.7 2: {2C148B86-FF80-49A7-BA18-E4CEF6464AE6} 
1: Action 10:22:06: FindRelatedProducts. Searching for related applications
1: Action 10:22:06: AppSearch. Searching for installed applications
1: Property: OLDVERSION, Signature: Ver5081
1: Property: OLDVERSION, Signature: Ver507
1: Property: OLDVERSION, Signature: Ver506
1: Property: OLDVERSION, Signature: Ver505
1: Property: OLDVERSION, Signature: Ver504
1: Property: OLDVERSION, Signature: Ver503
1: Property: OLDVERSION, Signature: Ver502
1: Property: OLDVERSION, Signature: Ver501
1: Property: OLDVERSION, Signature: Ver500
1: Property: PREUPGRADEVERSION, Signature: Pre638
1: Property: PERUSERINSTALL, Signature: Reg638
1: Property: PERUSERINSTALL, Signature: Reg644
1: Property: HLM_LOCATION, Signature: HLMRegSearch
1: Property: NETFRAMEWORK20, Signature: NetFramework20
1: Property: NETFRAMEWORK40FULL, Signature: NetFramework40Full
1: Action 10:22:06: LaunchConditions. Evaluating launch conditions
1: Action 10:22:06: ValidateProductID. 
1: Action 10:22:06: CostInitialize. Computing space requirements
1: Action 10:22:06: FileCost. Computing space requirements
1: Action 10:22:06: CostFinalize. Computing space requirements
1: Action 10:22:06: InstallValidate. Validating install
1: Action 10:22:06: Setv2InstallUtil. 
1: Action 10:22:06: Setv4InstallUtil. 
1: Action 10:22:06: InstallInitialize. 
1: Action 10:22:06: GenerateScript. Generating script operations for action:
1: InstallInitialize
1: Action 10:22:06: RemoveExistingProducts. Removing applications
1: Action 10:22:06: ProcessComponents. Updating component registration
1: 
1: Action 10:22:06: MsiUnpublishAssemblies. Unpublishing assembly information
1: Application Context:Unpublishing assembly information, Assembly Name:
1: Action 10:22:06: UnpublishFeatures. Unpublishing Product Features
1: Feature: Unpublishing Product Features
1: Action 10:22:06: UninstallPerfCounterData. 
1: Action 10:22:06: RollbackUnregisterPerfCounterData. 
1: 
1: Action 10:22:06: UnregisterPerfCounterData. 
1: 
1: Action 10:22:06: RemoveRegistryValues. Removing system registry values
1: Key: Removing system registry values, Name: 
1: Action 10:22:06: RemoveShortcuts. Removing shortcuts
1: Shortcut: Removing shortcuts
1: Action 10:22:06: ManagedDataUnInstallSetup. 
1: Action 10:22:06: ManagedDataUnInstall. Unregistering data provider from machine.config
1: Action 10:22:06: ManagedWebUnInstallSetup. 
1: Action 10:22:06: ManagedWebUnInstall. Unregistering web providers from machine.config
1: Action 10:22:06: RemoveFiles. Removing files
1: File: Removing files, Directory: 
1: Action 10:22:07: RemoveFolders. Removing folders
1: Folder: Removing folders
1: Action 10:22:07: CreateFolders. Creating folders
1: Action 10:22:07: InstallFiles. Copying new files
1: Action 10:22:07: CreateShortcuts. Creating shortcuts
1: Action 10:22:07: WriteRegistryValues. Writing system registry values
1: Action 10:22:07: InstallPerfCounterData. 
1: Action 10:22:07: RegisterUser. Registering user
1: Action 10:22:07: RegisterProduct. Registering product
1: Action 10:22:07: MsiPublishAssemblies. Publishing assembly information
1: Action 10:22:07: PublishFeatures. Publishing Product Features
1: Action 10:22:07: PublishProduct. Publishing product information
1: 
1: Action 10:22:07: InstallFinalize. 
1: Action 10:22:07: InstallInitialize. 
1: Action 10:22:07: ProcessComponents. Updating component registration
1: Action 10:22:07: MsiUnpublishAssemblies. Unpublishing assembly information
1: Application Context:Global, Assembly Name:MySql.Data,version="6.9.7.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:MySql.Data,version="6.9.7.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:MySql.Web,version="6.9.7.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:MySql.Web,version="6.9.7.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:MySql.Data.CF,version="6.9.7.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:MySql.Data.Entity,version="6.9.7.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Application Context:Global, Assembly Name:MySql.Data.Entity,version="6.9.7.0",culture="neutral",publicKeyToken="C5687FC88969C44D",processorArchitecture="MSIL"
1: Action 10:22:07: UnpublishFeatures. Unpublishing Product Features
1: Feature: EntityFramework
1: Feature: Samples
1: Feature: Plugins
1: Feature: DocsFeature
1: Feature: Core.Feature
1: Feature: WebProviders
1: Feature: CompactFramework
1: Feature: CSSamples
1: Feature: VBSamples
1: Feature: Plugins.Fabric
1: Action 10:22:07: RollbackUnregisterPerfCounterData. 
1: Action 10:22:07: UnregisterPerfCounterData. 
1: Action 10:22:07: RemoveRegistryValues. Removing system registry values
1: Key: \Software\MySQL AB, Name: Default
1: Key: \Software\MySQL AB\MySQL Connector/Net, Name: Version
1: Key: \Software\MySQL AB\MySQL Connector/Net, Name: Location
1: Key: \Software\MySQL AB\MySQL Connector/Net, Name: 
1: Key: \SOFTWARE\Microsoft\.NETFramework\v2.0.50727\AssemblyFoldersEx\MySQL Connector Net 6.9.7 v2.0, Name: 
1: Key: \SOFTWARE\Microsoft\.NETFramework\v2.0.50727\AssemblyFoldersEx\MySQL Connector Net 6.9.7 v2.0, Name: 
1: Key: \SOFTWARE\Microsoft\.NETFramework\v4.0.30319\AssemblyFoldersEx\MySQL Connector Net 6.9.7 v4.0, Name: 
1: Key: \SOFTWARE\Microsoft\.NETFramework\v4.0.30319\AssemblyFoldersEx\MySQL Connector Net 6.9.7 v4.0, Name: 
1: Key: \SOFTWARE\Microsoft\.NETFramework\v4.5.50709\AssemblyFoldersEx\MySQL Connector Net 6.9.7 v4.5, Name: 
1: Key: \SOFTWARE\Microsoft\.NETFramework\v4.5.50709\AssemblyFoldersEx\MySQL Connector Net 6.9.7 v4.5, Name: 
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Linkage, Name: Export
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: 
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Library
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Open
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Collect
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Close
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: IsMultiInstance
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Counter Names
1: Key: \SYSTEM\CurrentControlSet\Services\.NET Data Provider for MySQL\Performance, Name: Counter Types
1: Action 10:22:07: RemoveShortcuts. Removing shortcuts
1: Shortcut: upfn1-0t|Documentation
1: Shortcut: vaitcdd6|ChangeLog
1: Shortcut: _rq6aex9|Release Notes
1: Action 10:22:07: ManagedDataUnInstall. Unregistering data provider from machine.config
1: 1: MySQL Connector Net 6.9.7 2: {2C148B86-FF80-49A7-BA18-E4CEF6464AE6} 3: 3 
1: Action 10:22:08: Rollback. Rolling back action:
1: Unregistering data provider from machine.config
1: Removing shortcuts
1: Removing system registry values
1: UnregisterPerfCounterData
1: RollbackUnregisterPerfCounterData
1: Unpublishing Product Features
1: Unpublishing assembly information
1: Updating component registration
1: InstallInitialize
1: 1: MySQL Connector Net 6.9.9 2: {E09F82E9-3EB3-4725-BDC8-3C77F83E262C} 3: 3 
1: The action 'Upgrade' for product 'Connector/NET 6.9.9' failed.
[31 Mar 2017 9:41] Chiranjeevi Battula
Hello Sindre,

Thank you for the bug report.
I tried to reproduce the issue at my end using MySQL Connector/Net 6.9.9 but not seeing any issues in installation.
Download from here: https://dev.mysql.com/downloads/connector/net/6.9.html
installation manual:
https://dev.mysql.com/doc/connector-net/en/connector-net-installation-binary-windows-insta...
https://dev.mysql.com/doc/visual-studio/en/visual-studio-install.html

Thanks,
Chiranjeevi.
[31 Mar 2017 14:30] Farah Hussein
Hi Chiranjeevi 

I have tried the link you send and still installation ended prematurely.
I got the following:
Mysql Connector Net 6.9.9 Setup Wizard ended prematurely because pf an error. Your system has not been modified. To install this program at later time, run setup wizard again. Click the Finish button to exit the setup Wizard.

Thanks,
Farah
[4 Apr 2017 9:59] Chiranjeevi Battula
Hello Farah,

Thank you for the feedback.
This is most likely duplicate of Bug #62606, please see Bug #62606.

Thanks,
Chiranjeevi.
[4 Apr 2017 20:18] Farah Hussein
Hello Chiranjeevi 

I tried to uninstall the registry 
HKLM\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{2DDC7E93-29AB-4260-A9DB-697F7FA88157}
HKLM\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{5FD88490-011C-4DF1-B886-F298D955171B}
but i am not able to see them on my machine how to find what registry is using my current connector 6.9.7

Best Regards,
Farah