Bug #85231 Unable to create backup using MEB 4.0.3 with mysql version 5.7.11
Submitted: 28 Feb 2017 14:59 Modified: 6 Mar 2017 9:27
Reporter: Steven Stritz Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Enterprise Backup Severity:S3 (Non-critical)
Version:4.0.3 OS:Microsoft Windows (Server 2012 R2)
Assigned to: CPU Architecture:Any
Tags: 4.0.3, 5.7.11, Backup, meb, MySQL, mysql enterprise backup, mysqlbackup, version

[28 Feb 2017 14:59] Steven Stritz
Description:
Hey there,

I tried to create a backup using MEB 4.0.3 with the mysql-5.7.11-winx64 version.

Syntax is similar to this, and it worked when I was using mysql 5.7.17.

mysqlbackup -u root -p <password> --backup-image=DBname.mbi --backup-dir=%temp% backup-to-image

Is it intended to work like this? 
Here's the error message:

mysqlbackup: INFO: Starting with following command line ...
 mysqlbackup.exe -u root -pxxxxxxxxxxxxxx --with-timestamp
        --backup-image=DBname.mbi
        --backup-dir=C:\Temp\ backup-to-image

 mysqlbackup: INFO:
 mysqlbackup: INFO: MySQL server version is '5.7.11-log'
 mysqlbackup: INFO: MySQL server compile os version is 'Win64'
 mysqlbackup: INFO: Got some server configuration information from running server.

IMPORTANT: Please check that mysqlbackup run completes successfully.
           At the end of a successful 'backup-to-image' run mysqlbackup
           prints "mysqlbackup completed OK!".

170228 15:46:48 mysqlbackup: INFO: MEB logfile created at C:\temp\MEB_2017-02-28.15-46-48_imag
e_backup.log

 mysqlbackup: INFO: Encryption password "encrypt-password" not specified.
 mysqlbackup: ERROR: Invalid options, MEB would not be able backup encrypted tables.

mysqlbackup failed with errors!

I already tried using a lower version of MEB, 3.12.3 for example but it turned out that it is not compatible with this mysql version.

How to repeat:
See Description
 

Suggested fix:
The same command worked under mysql version 5.7.17
For the time being no way to create a backup with mysqlbackup.exe on mysql version 5.7.11
[3 Mar 2017 8:05] MySQL Verification Team
Hello Steven Stritz,

Thank you for the report.
Could you please confirm whether 5.7.11 has keyring plungin enabled? Imho, MEB complains when it encounter plugin enabled and you are not using the option --encrypt-password while backing up using MEB - https://dev.mysql.com/doc/mysql-enterprise-backup/4.0/en/backup-encrypted-innodb-options.h...

mysqlbackup: INFO: Encryption password "encrypt-password" not specified. 
mysqlbackup: ERROR: Invalid options, MEB would not be able backup encrypted 
tables.  

Thanks,
Umesh
[3 Mar 2017 8:06] MySQL Verification Team
-- Looks like in 5.7.11, keyring plugin active by default(unusuable unless path etc provided)

[umshastr@hod03]/export/umesh/server/binaries/GABuilds/mysql-5.7.11: bin/mysql -uroot -S /tmp/mysql_ushastry.sock
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 2
Server version: 5.7.11-enterprise-commercial-advanced MySQL Enterprise Server - Advanced Edition (Commercial)

Copyright (c) 2000, 2016, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

root@localhost [(none)]> show plugins;
+----------------------------+----------+--------------------+-----------------+-------------+
| Name                       | Status   | Type               | Library         | License     |
+----------------------------+----------+--------------------+-----------------+-------------+
| keyring_file               | ACTIVE   | KEYRING            | keyring_file.so | PROPRIETARY |
[6 Mar 2017 9:12] Steven Stritz
Disabled the keyring-file plugin so the problem solved itself. It is now working with the version 5.7.11. Thank you very much!
[6 Mar 2017 9:27] MySQL Verification Team
Thank you for confirming!
Closing the bug now.

Thanks,
Umesh