Bug #83837 App crashes consistently after every 3rd or 4th query
Submitted: 16 Nov 2016 8:10 Modified: 22 Nov 2016 8:18
Reporter: Clint Kahler Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.7 OS:Mac OS X (unknown)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[16 Nov 2016 8:10] Clint Kahler
Description:
02:02:04 [INF][      Workbench]: Starting up Workbench
02:02:04 [INF][      WBContext]: Parsing application arguments.
02:02:04 [INF][      WBContext]:     /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
02:02:04 [INF][      WBContext]:     -psn_0_29609019
02:02:04 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /Applications/MySQLWorkbench.app/Contents/Resources
	plugin path: /Applications/MySQLWorkbench.app/Contents/PlugIns
	struct path: /Applications/MySQLWorkbench.app/Contents/Resources/grt
	module path: /Applications/MySQLWorkbench.app/Contents/PlugIns:/Applications/MySQLWorkbench.app/Contents/Resources/plugins
	library path: /Applications/MySQLWorkbench.app/Contents/Resources/libraries
	user data dir: /Users/username/Library/Application Support/MySQL/Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
02:02:04 [INF][      WBContext]: WbContext::init
02:02:05 [INF][            WBA]: Looking for extension modules for WBA...
02:02:05 [INF][            WBA]: 0 extension modules found
02:02:05 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
02:02:05 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
02:02:05 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
02:02:05 [WRN][            grt]: /Users/username/Library/Application Support/MySQL/Workbench/connections.xml:26: link 'FB598124-764F-4AA9-9DDF-2EBC7AE4969A' <object GrtObject> key=owner could not be resolved
02:02:05 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Mac OS X version 6.3.7 CE build 1199 (64 bit)
	Configuration Directory: /Users/username/Library/Application Support/MySQL/Workbench
	Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
	Cairo Version: 1.10.2
	OS: unknown
	CPU: 8x Intel(R) Core(TM) i7-4960HQ CPU @ 2.60GHz - 16.00GiB RAM

02:02:05 [INF][    WQE backend]: Found auto-save workspace /Users/username/Library/Application Support/MySQL/Workbench/sql_workspaces/-1.autosave
02:02:05 [INF][    WQE backend]: Found auto-save workspace /Users/username/Library/Application Support/MySQL/Workbench/sql_workspaces/PROD-1.autosave

How to repeat:
Run a query against any table a couple times and the app crashes.
[17 Nov 2016 13:41] Doug Couvillion
I have been experiencing this problem too.  If you run more than 5 queries you’re almost guaranteed to crash Workbench.  I’m running MySQL Workbench 6.3.7 on macOS Sierra 10.12.1.
[22 Nov 2016 8:18] Chiranjeevi Battula
Hello Clint Kahler,

Thank you for the bug report.
This is most likely duplicate of Bug #82951, Please check the workaround(set SSH keepalive(default is disabled)  to 30 sec or 60 sec) mentioned in Bug #82951 will helps you.

Thanks,
Chiranjeevi.