Bug #82951 Editor seems to crash MySQL Workbench without warning.
Submitted: 12 Sep 2016 16:57 Modified: 25 Jan 2017 20:49
Reporter: Derek Gau Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:6.3.7 OS:Mac OS X (OS X 10.11.x El Capitan)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[12 Sep 2016 16:57] Derek Gau
Description:
The SQL editor crashes when running SQL scripts. I was connected to a MySQL database on AWS, and just doing run-of-the-mill queries (simple select, update) statements. Doesn't seem to have a pattern, but the Workbench just crashes and disappears. Restarting the workbench buys a few more minutes and then the problem recurs. 

----[For better reports, please attach the log file after submitting. You can find it in /Users/Derek/Library/Application Support/MySQL/Workbench/log/wb.log]

How to repeat:
Very difficult to say for sure. I have a saved .SQL file that I have been using to run various queries to my database. The queries are very simple, for example 

select * from t_user_organization where user_id=3;

I also got the behavior running a one-row update statement as well.
[15 Sep 2016 11:35] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83004 marked as duplicate of this one.
[15 Sep 2016 14:08] Hung Nguyen Thanh
I have faced the same issues with aws database server. The crash log has been attached to my log page
[22 Sep 2016 22:23] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83105 marked as duplicate of this one.
[29 Sep 2016 21:52] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83213 marked as duplicate of this one.
[18 Oct 2016 18:00] Jonathan D
Any update on this? To get a simple select all query to run I had to quit and re-open the app 7 times. It's barely usable at this point.
[21 Oct 2016 16:28] Miguel Solorzano
Please try version 6.3.8. Thanks.

http://dev.mysql.com/downloads/workbench/
[26 Oct 2016 12:51] Jonathan D
6.3.8 doesn't help it still hangs all the time. I just had the 'you cant close while busy' message after connecting to a server and I haven't run a query yet.
[28 Oct 2016 10:22] Chiranjeevi Battula
Hello Jonathan,

Thank you for your feedback.
How you are connecting to AWS is SSH or TPC/IP with SSL?.
If you are using SSH, could you please try with this workaround to set SSH keepalive(default is disabled)  to 30 sec or 60 sec (you have to try which one value works for you).
If could not help above workaround, please provide us how you are connecting with details like (sample connection details, error screenshot, log file etc. - please make it as private if you prefer) to confirm this issue at our end?

Thanks,
Chiranjeevi.
[29 Oct 2016 23:41] Rick Hubbard
MSW Spinning Wheel of Doom Attempting Remote Query

Attachment: MSW-Spinning-Wheel-of-Doom.jpg (image/jpeg, text), 132.02 KiB.

[29 Oct 2016 23:41] Rick Hubbard
MSW v6.3.8 running on a Mac (macOS Sierra 10.12.1) after successful “Test Connection” (in MSW’s Connector dialog) experiences intermittent, then total, failure trying to run remote queries to AWS (Amazon Web Services) RDS instances…both AWS-MySQL and AWS-Aurora. 

Sometimes queries work…most times they result in a Spinning Wheel of Doom (see attached image…and logs are attached too—although I cannot find where to set WB_LOG_LEVEL=3). 

FYI: Sequel Pro and Jetbrain’s DataGrip do not seem to have these problems. 

THIS JUST IN…a collegue using MSW v6.3.8 on a Windows 10 machine reports the same problem (trying to access the same AWS databases mentioned above).
[29 Oct 2016 23:44] Rick Hubbard
wb.log

Attachment: wb.log (application/octet-stream, text), 5.37 KiB.

[31 Oct 2016 9:48] Chiranjeevi Battula
Hello Rick Hubbard,

Thank you for your feedback.
Verified based on internal discussion with dev's.

Thanks,
Chiranjeevi.
[31 Oct 2016 9:53] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=83614 marked as duplicate of this one.
[31 Oct 2016 13:20] Jonathan D
I get the same issue on my local MySQL install (TCP) and both our AWS databases (one Aurora one MySQL) also over TCP.

I open the app, type a query and click execute. The activity indicator on the tab starts to spin and never returns a result so I have to force quit the app.

I have no issues at all on either DB server using SequelPro.
[22 Nov 2016 8:16] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=82458 marked as duplicate of this one.
[22 Nov 2016 8:18] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=83837 marked as duplicate of this one.
[30 Nov 2016 17:34] Rick Hubbard
MSW v6.3.8 running on macOS 10.12.1 fails to execute a simple query (USE database_name;) against a localhost:8889 instance of MySQL (MAMP PRO v4.0.6 with MySQL v5.6.33)--the only result is the spinning wheel of doom.

Because there are no such problems executing far more complex queries against localhost:8889 using JetBrain's DataGrip and Sequel Pro (both for Mac; no problems...the queries execute virtually instantly)...it seems that MSW and/or MSW's Data Connectors continue to be the problem. HOWEVER, what's usual about this case is...until about a week ago, the same version of MSW was able to access the localhost:8889 MySQL databases without a hitch. 

At the moment, MSW's query functionality is completely unusable...both on localhost and remotely (see my prior post in this thread about remote access).

Hope the developer team can quickly resolve this serious bug as there's no point in using MSW until they can do so.
[11 Jan 2017 20:11] Jonathan D
Any update to this? The app has been unusable for several months now.
[12 Jan 2017 10:24] Benoit Lathiere
I have te same problem. Context :
MacOS sierra 10.12.2
Mysql Workbench 6.3.7

/!\ I updated MacOS two days ago (from 10.9 Mavericks) and all worked fine before that. I don't have any other problem on the Mac.

Symptoms :
I connect to a distant mysql DB through a SSL connection. The connection test is passed.
When I execute a (simple or complex) query, the execution still runs without any issue (the famous Spinning Wheel of Doom Attempting Remote Query). And I can't stop the execution (the icon "white hand on red disc" is disabled).
I have the same problem with different servers/mysql versions.
[18 Jan 2017 9:27] Benoit Lathiere
I just updated Java to the version 121 (critical update btw) and MSW seems to work fine!
[20 Jan 2017 7:21] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=84568 marked as duplicate of this one.
[20 Jan 2017 7:21] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=84570 marked as duplicate of this one.
[25 Jan 2017 20:49] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 6.3.9 release, and here's the changelog entry:

Simple and complex queries executed from SQL Editor failed to complete and
return control to MySQL Workbench. This behavior was observed for both
local and remote queries and was often intermittent.

Thank you for the bug report.
[30 Jan 2017 7:32] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=84700  marked as duplicate of this one.
[2 Jun 2017 18:35] Pinal Shah
I have the MYSQL workbench 6.3.9 and still the client timeout while the long running query gives perfect  results on Sequel Pro on Mac. Please fix this for god sake or people will start moving towards Mac
[13 Oct 2017 14:34] Barry McClendon
10/13/17 09:32 AM - Version 6.3.9 of workbench on MacOS 10.13 same symptoms occurring.