Bug #83769 Start MySql server from MySql Workbench hangs MySql Workbench several minutes
Submitted: 10 Nov 2016 10:08 Modified: 23 Feb 10:10
Reporter: Roland Beuker Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S5 (Performance)
Version:6.3.8 OS:Mac OS X (macOS 10.12.x Sierra)
Assigned to:
Tags: WBBugReporter

[10 Nov 2016 10:08] Roland Beuker
Description:
----[For better reports, please attach the log file after submitting. You can find it in /Users/rcbeuker/Library/Application Support/MySQL/Workbench/log/wb.log]

When i start MySql server from MySql Workbench, MySql Workbench hangs for several minutes.

More important: when MySql Workbench is started this way it fixes bug #83766, #83658 and #83625

How to repeat:
Do not start MySql server at system startup
Start MySql Workbench
Connect local database
At 'Instance' choose start server
MySql Workbench hangs ...

But after several minutes MySql Workbench continuous working.
Without the 'query-bug' 

Suggested fix:
Take a cup of coffee and wait ...
[10 Nov 2016 14:58] Miguel Solorzano
Thank you for the bug report.
[8 Dec 2016 9:46] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83914 marked as duplicate of this one.
[8 Dec 2016 19:07] Roland Beuker
Is there any change this bug will be resolved on short term?
At this moment i cannot work with MySql Workbench with my Apple workspace.
[16 Jan 20:32] Loren Brown
Adding another voice of EXTREME frustration over this hanging issue!!!!
[18 Jan 10:53] Roland Beuker
My first comment with start, and wait for several minutes is not working anymore!
Starting MySql outside Workbench isn't working either because in this situation Workbench doesn't work with the local database (it just hangs on every call).

PLEASE FIX THIS ISSUE!
[10 Feb 21:49] Loren Brown
I am delighted that this issue appears to be fixed in 6.3.9.
THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[23 Feb 10:07] Roland Beuker
Yes, i can work (again) with version 6.3.9 :)

There's still a minor issue; i cannot start MySql server from the workbench without hanging MySqlWorkbench (i have to start MySql server outside the workbench).
[23 Feb 10:10] Roland Beuker
There one small bug with version 6.3.9 (cannot start server from workbench) but i can work with this version.

Thank you!