Bug #83766 MysSql Workbench doesn't run queries anymore
Submitted: 10 Nov 2016 8:48 Modified: 10 Nov 2016 9:37
Reporter: Roland Beuker Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.8 OS:Mac OS X (macOS 10.12.x Sierra)
Assigned to:
Tags: WBBugReporter

[10 Nov 2016 8:48] Roland Beuker
Description:
----[For better reports, please attach the log file after submitting. You can find it in /Users/rcbeuker/Library/Application Support/MySQL/Workbench/log/wb.log]

After the switch to Mac OSX 10.12.1 MySql Workbench doesn't run queries anymore.
It just starts showing a waiting cursor and nothing happens...

The same query works fine via JDBC or a tool like Querious.
This is a sometimes situation (60/40) but when the error appears it keeps going wrong.
Even a reboot from the Mac doesn't resolve this.

I'm working with MySql Ver. 14.14. Distrib 5.7.16 for osx10.11

How to repeat:
Start a Mac Pro with OSX 10.12.1
Start MySql server Ver. 14.14. Distrib 5.7.16 for osx10.11
Start MySql Workbench 6.3.8
Run an ALL query

MySql Workbench 'hangs' with a waiting cursor.
[10 Nov 2016 8:49] Roland Beuker
Query hangs ...

Attachment: Screen Shot 2016-11-10 at 09.37.10.png (image/png, text), 99.10 KiB.

[10 Nov 2016 8:51] Roland Beuker
The log file doesn't show an error

Attachment: wb.log (application/octet-stream, text), 2.50 KiB.

[10 Nov 2016 9:29] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.
[10 Nov 2016 9:37] Roland Beuker
Indeed duplicate;

For the questions on the other posts; i'm running MySql server on the same machine as MySql Workbench.

The extra tab 'trick' isn't working here, and even a hard-reboot from the system isn't solving the problem.