Bug #81226 i_s.processlist should not whine about incorrect strings
Submitted: 28 Apr 2016 20:30 Modified: 29 Apr 2016 6:04
Reporter: Domas Mituzas Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Information schema Severity:S3 (Non-critical)
Version:5.6,5.6.30, 5.7.12, 8.0.0 OS:Any
Assigned to: CPU Architecture:Any

[28 Apr 2016 20:30] Domas Mituzas
Description:
if query is not a valid unicode string (e.g. has binary data in it), SELECT id FROM information_schema.processlist will return a warning:

Incorrect string value: '\xF2\xAE\x89A5\x1F...' for column 'INFO' at row 1

Technically, this is incorrect, because the string value is definitely correct, as that query executes and produces consistent results.

That even happens if my character set is 'binary'. 
That makes it impossible to retrieve query texts from processlit, as well as is throwing warnings for no reason and making poor DBA worry.

How to repeat:
s1: SELECT 'binary gibberish',SLEEP();
s2: SELECT id FROM information_schema.processlist;

Suggested fix:
don't treat processlist as utf8, allow proper binary access.
[29 Apr 2016 4:54] Shane Bester
Bug 11751162 - WARNING 1366 INCORRECT STRING VALUE: ... FOR COLUMN PROCESSLIST.INFO 
http://bugs.mysql.com/bug.php?id=41925
[29 Apr 2016 6:04] Umesh Shastry
Hello Domas,

Thank you for the report.
As Shane confirmed, this is duplicate of Bug #41925

Thanks,
Umesh
[18 Jun 2016 21:37] Omer Barnir
Posted by developer:
 
Reported version value updated to reflect release name change from 5.8 to 8.0