Bug #7758 MS Query crashes when creating query with System/User DSN
Submitted: 10 Jan 2005 8:57 Modified: 21 May 2007 6:17
Reporter: Tomas Rollo Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:3.51 OS:Microsoft Windows (WinXP Sp2)
Assigned to: CPU Architecture:Any

[10 Jan 2005 8:57] Tomas Rollo
Description:
I tried to use MyODBC to retrieve data from MySQL db to MS Excel sheet, however as soon as MS Query opens up, it crashes with following error:

"Instruction on address 0x100089f3 referenced to memory address 0x00000000. An operation cannot be performed on the memory: read."

(the message is not exactly this, I have a Czech version of MS Office and this is my translation to English)

Event log gets this info (my translation again):

Event type:	Information
Event source:	DrWatson
Event category:	Not available
Event ID:	4097
Date:		10.1.2005
Time:		9:02:00
User:		Not available
Computer:	GR0122
Description:
Aplication C:\Program Files\Microsoft Office\OFFICE11\msqry32.exe generated application error. Generated exception: c0000005 on address 100089F3 (myodbc3!SQLGetInfo)

The dump data can be provided.

Overall system info:
OS: Windows XP Sp2 Czech version
MS Office 2003 SB Czech version
MyODBC 3.51.10-2

The instalation was errorless, configuration as well (through Data Sources Control Panel), even the test reports success in connection to the DB.

How to repeat:
Directly via Msqry32:
1) Locate and run Msqry32.exe
2) Go to File->New
3) Select your MyODBC data source
4) As soon as you click OK, the error pops up and Msqry32 crashes

Suggested fix:
Unknown
[11 Jan 2005 18:13] Jorge del Conde
Reproduced with Office 2003
[13 Jan 2005 20:40] Mark De Quidt
I have a similar error in OpenOffice 1.1.4 Dutch.  Windows XP Home SP2 Dutch, MySQL 4.0.23 (4.1 gave a password incompatibility with PHP), ODBC 3.51.10:

- Creating a User DSN without problem (localhost, database "test")
- Data Source shows up in Open Office without problem,
- but when pressing right mouse click on a Database Table, OO crashes with:
-- appname = soffice.exe
-- appver = 6.0.8824.500
-- modname = myodbc3.dll
-- modver = 3.51.10.0
-- offset 000090a0

From msquery, simple access crashes also:
-- application = msqry32.exe
-- version = 10.0.2607.0
-- module = myodbc3.dll
-- version = 3.51.10.0
-- 0x000089f3

Thx, Mark.
[17 Jan 2005 16:30] Carole Duvoisin
I have the same problem with windows xp and office 2003.
[28 Jan 2005 17:22] Kevin Oliver
Experienced the same problem with the recommended download 28-Jan-05
[23 Nov 2006 9:07] Tonci Grgin
Correction, MSQRY32.EXE crashes with System/User DSN but works with File DSN. This is repeatable with 3.51.13 too. There seems to be more in this; when first encountering erroneous query, you'll get "MySQL server has gone away" message which is not true according to server error log (server is running normally).
Logs attached.
[23 Nov 2006 9:09] Tonci Grgin
ODBC trace and server logs for all of tests mentioned

Attachment: Bug7758-logs.zip (application/x-zip-compressed, text), 25.65 KiB.

[1 Feb 2007 9:38] Tonci Grgin
Please try solution from Bug#25850 .
[21 May 2007 6:17] Tonci Grgin
This is a duplicate of Bug#4657. New report for v5 opened in Bug#28546.