Bug #25850 "Don't Cache Result" makes MSQRY32.EXE crash
Submitted: 25 Jan 2007 15:08 Modified: 27 Apr 2007 17:09
Reporter: Jens H. Nielsen Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S1 (Critical)
Version:3.51.12 OS:Microsoft Windows (Windows Server 2003)
Assigned to: Bogdan Degtyariov CPU Architecture:Any
Tags: Don't Cache Result

[25 Jan 2007 15:08] Jens H. Nielsen
Description:
I trying to access large tabels, but can't becouse of a bug in the ODBC driver.

I have attach a trace from ODBC DATA SOURCE Administrator.

How to repeat:

- In ODBC driver set the "Don't Cache Result" flag
- open MSQRY32.EXE
- try to open the data source
- MSQRY32 exits

 

Suggested fix:
?
[25 Jan 2007 15:08] Jens H. Nielsen
Trace

Attachment: SQL.LOG (application/x-sas-log, text), 32.45 KiB.

[26 Jan 2007 10:28] Jens H. Nielsen
Output from Event Viewer

Event Type:	Error
Event Source:	Application Error
Event Category:	(100)
Event ID:	1000
Date:		26-01-2007
Time:		11:26:32
User:		N/A
Computer:	BBS-SASSERVER
Description:
Faulting application MSQRY32.EXE, version 9.0.0.2612, faulting module myodbc3.dll, version 3.51.13.0, fault address 0x0000f1bc.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 4d 53 51   ure  MSQ
0018: 52 59 33 32 2e 45 58 45   RY32.EXE
0020: 20 39 2e 30 2e 30 2e 32    9.0.0.2
0028: 36 31 32 20 69 6e 20 6d   612 in m
0030: 79 6f 64 62 63 33 2e 64   yodbc3.d
0038: 6c 6c 20 33 2e 35 31 2e   ll 3.51.
0040: 31 33 2e 30 20 61 74 20   13.0 at 
0048: 6f 66 66 73 65 74 20 30   offset 0
0050: 30 30 30 66 31 62 63      000f1bc
[26 Jan 2007 10:29] Jens H. Nielsen
I know it says version 3.51.13.0, but I tryed installing the new version to see if the bug was fixed. So the bug is also in 3.51.13.0.
[29 Jan 2007 11:11] Jens H. Nielsen
I forgot the database version.

I use 5.0.22-community-nt-log.
[29 Jan 2007 14:13] Tonci Grgin
Hi Jens and thanks for your problem report. Verified as described by reporter on:
 - MySQL 5.0.34BK on WinXP Pro SP2 localhost
 - MSQRY32 11.0.5510.0
 - MyODBC 3.51.13 Rev 146
If "Don't cache result" is False, everything works as expected.
[29 Jan 2007 14:20] Tonci Grgin
Probably related to Bug#7758
[31 Jan 2007 15:09] Bogdan Degtyariov
This bug is related to #4657.
Fixed version of myodbc3.dll is available from here:
ftp://ftp.mysql.com/pub/mysql/download/connectors/odbc/mysql-connector-odbc-3.51.13r145_20...
[1 Feb 2007 21:38] Jens H. Nielsen
Great !

Thanks a lot
Jens
[7 Mar 2007 13:39] Per Lindström
I use Cognos (a reporting and analysis tool) and we connect to our MySQL datasource (5.0.27) through the ODBC driver 3.51.12, we have experienced some Out-of-memory exceptions in the ODBC driver and a suggestion has been given to us that we should check the "Don't cache result" property to avoid this problem. When we do this we can't connect to the database anymore from Cognos and Excel crashes if we try it from there. Following this bug we have downloaded 3.51.13 and updated the myodbc3.dll file, now it works fine from Excel and the operation from Cognos works fine but if we continue to do more operations against the MySQL database we get the error message 

[MySQL][ODBC 3.51 Driver][mysqld-5.0.27-standard-log]Commands out of sync; you can't run this command now

What can the reason be?
[27 Apr 2007 17:09] Jim Winstead
This is a duplicate of Bug #4657.