Bug #77482 Add RESET MASTER TO x to allow specification of binlog file nr (contribution)
Submitted: 25 Jun 2015 11:47 Modified: 23 May 2017 5:56
Reporter: OCA Admin (OCA) Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Replication Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D5 (Feature request)

[25 Jun 2015 11:47] OCA Admin
Description:
This bug tracks a contribution by Daniël van Eeden (Github user: dveeden) as described in http://github.com/mysql/mysql-server/pull/14

How to repeat:
See description

Suggested fix:
See contribution code attached
[25 Jun 2015 11:47] OCA Admin
Contribution submitted via Github - Add RESET MASTER TO x to allow specification of binlog file nr 
(*) Contribution by Daniël van Eeden (Github dveeden, mysql-server/pull/14#issuecomment-114861636): I confirm the code being submitted is offered under the terms of the OCA, and that I am authorized to contribute it.

Contribution: git_patch_38379553.txt (text/plain), 9.49 KiB.

[25 Jun 2015 12:22] Umesh Shastry
Hello Daniël,

Thank you for the report and contribution.

Thanks,
Umesh
[26 Jun 2015 8:26] Daniël van Eeden
This is for Bug #77438
[16 May 2017 9:42] David Moss
Thanks for your contribution, this was included in MySQL 8.0.1 and the following was added to the change log:
The RESET MASTER statement has been extended to allow specification of a binary log file number. The RESET MASTER TO statement accepts an argument which specifies the index of the new binary log file to use. The purpose is to simplify failover procedures by replacing the FLUSH BINARY LOGS and PURGE BINARY LOGS TO statements with a single RESET MASTER statement. 

The reference manual documentation here was updated:
https://dev.mysql.com/doc/refman/8.0/en/reset-master.html
[12 Feb 7:36] Umesh Shastry
Bug #77438 marked as duplicate of this one