Bug #77438 Extend RESET MASTER to allow specifying next binary log.
Submitted: 22 Jun 2015 15:46 Modified: 12 Feb 7:36
Reporter: Jean-François Gagné Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Replication Severity:S4 (Feature request)
Version:5.7 OS:Any
Assigned to: CPU Architecture:Any
Tags: replication
Triage: Needs Triage: D5 (Feature request)

[22 Jun 2015 15:46] Jean-François Gagné
Description:
Hi,

I would like the "RESET MASTER" command to be extended in the following way:

RESET MASTER [AT file_number]

where file_number would be the binary log index of the next binary log to create: instead of being <log_bin_basename>.000001, the next binary log file would be <log_bin_basename>.<file_number>.

This would allow to perform easy master promotion as discussed at slide # 31 of the below URL without "FLUSH BINARY LOGS" in a loop:
-http://www.slideshare.net/JeanFranoisGagn/binlog-servers-at-bookingcom

So if I have "log-bin = binlog" in my.cnf, a "RESET MASTER AT 1234" would generate "binlog.001234" as the next binary log file.

Many thanks,

JFG

How to repeat:
Not a bug, but a feature request.

Suggested fix:
Not a bug, but a feature request.
[23 Jun 2015 20:33] Daniël van Eeden
Created pull request for this.
https://github.com/mysql/mysql-server/pull/14
[26 Jun 2015 8:25] Daniël van Eeden
The pull request is handled in Bug #77482
[12 Feb 7:36] Umesh Shastry
Bug #77482 is implemented with the below change log.

[16 May 2017 9:42] David Moss
Thanks for your contribution, this was included in MySQL 8.0.1 and the following was added to the change log:
The RESET MASTER statement has been extended to allow specification of a binary log file number. The RESET MASTER TO statement accepts an argument which specifies the index of the new binary log file to use. The purpose is to simplify failover procedures by replacing the FLUSH BINARY LOGS and PURGE BINARY LOGS TO statements with a single RESET MASTER statement. 

The reference manual documentation here was updated:
https://dev.mysql.com/doc/refman/8.0/en/reset-master.html