Bug #76687 Pivot Table Refresh All Not Working - Exception from HRESULT: 0x800A03EC
Submitted: 14 Apr 2015 10:06 Modified: 1 Jun 2015 15:08
Reporter: Danny Jager Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S2 (Serious)
Version:1.3.4 OS:Microsoft Windows (7 with SP1)
Assigned to: CPU Architecture:Any
Tags: excel 2010

[14 Apr 2015 10:06] Danny Jager
Description:
When I have the MySQL for Excel add-in active, Refresh All for pivot tables does not work. I can refresh individual pivot tables but not all of them at once.

I don't have any connection to a database and if I deactivate the add-in, everything works fine.

How to repeat:
Run Excel 2010 with MySQL for Excel 1.3.4 add-in active.

Try to Refresh All pivot tables and get MySQL error message  
Exception from HRESULT: 0x800A03EC. 
A screenshot is attached to this bug report
[14 Apr 2015 10:08] Danny Jager
Exception from HRESULT: 0x800A03EC - after click on refresh all

Attachment: Error Message After Click Refresh All.png (image/png, text), 174.70 KiB.

[14 Apr 2015 10:43] MySQL Verification Team
See http://bugs.mysql.com/bug.php?id=75565 it was closed as fixed for version 1.3.4.
[14 Apr 2015 11:16] Danny Jager
I'm running MySQL for Excel 1.3.4 on Excel 2010 SP2

Maybe the fix is only applied for Excel 2013 as it was mentioned on Bug #75565
[1 Jun 2015 15:08] Javier TreviƱo
The mentioned bug was fixed for all Excel versions.
Please help isolating what Pivot Table is causing the problem, you can do this by refreshing manually one by one.

Users have reported this error before and sometimes it is not related to MySQL for Excel, but to a broken connection or other causes.

More importantly, this problem may not be reproducible by us since on the steps to duplicate you say "Refresh all pivot tables" but an Excel Workbook no pivot tables initially. Please supply steps to duplicate this problem from scratch or attach an Excel file containing the pivot tables that cause this problem.