Bug #64443 Impossible to install the connector, due to left overs from earlier versions
Submitted: 24 Feb 2012 13:36 Modified: 25 Sep 2013 15:36
Reporter: Louis Breda van Email Updates:
Status: Can't repeat Impact on me:
Category:Connector / NET Severity:S2 (Serious)
Version:6.5.x OS:Windows (Windos7 64 bit)
Assigned to: Gabriela Martinez Sanchez CPU Architecture:Any
Tags: install, remove, uninstall

[24 Feb 2012 13:36] Louis Breda van

Today I tryed to update the 6.4.4. connector with 6.5.3.

That does not work. Same problem as reported before with earlier .net connector versions.

After uninstalling the 6.4.4 version, the 6.5.3 version does not install. You have to remove the ohter version first (but I did that allready!).

Luckely you can reinstall the 6.4.4. version from its msi. That works.

So, I am running 6.4.4 again, but this is never the less a longstanding very sevire problem.



How to repeat:
I do not exactly know when the bug occurs, but

- installing an older version
- use that version in .net
- remove the older version (my own .net programms where not running)
- try to install the new version

and you have a change it is bingo !! 

Suggested fix:
A couple of things need attention:
- the remove script should really remove every thing, and report (and log) if it can not remove something
- the install script should clearly describe why it can not install, which files and or registry entry's are blocking
[27 Feb 2012 21:32] Gabriela Martinez Sanchez
Hi Louis, could you please give us the steps that you're doing when uninstalling Connector/Net?. (for example if you are uninstalling it from the Control Panel or using the msi).

Thanks in advance.
[28 Feb 2012 5:34] Louis Breda van

I did try to deinstall the .net connector from the windows config screen / remove programm. 

And as indicated after the remove action from there, the program seems to be removed.

But that is not the perception of the installation programm related to the new version.


[28 Feb 2012 19:57] Gabriela Martinez Sanchez
thanks Louis, I did try that way too but I didn't have any problems with the next version. So I would like to ask you to run the msi using a shell window. Please use msiexec /x msifile /l*v logconnector.txt and attach the output file to this report, this way we can see what the problem is. Thanks in advance.
[28 Feb 2012 20:38] Louis Breda van
Logging from the not working mysql-connector-net-6.5.3.msi

Attachment: logconnector.txt (text/plain), 13.76 KiB.

[28 Feb 2012 20:46] Louis Breda van

I just added the logging from the connector.msi as requested in the preceding bug report comment.

For info
- I did remove the connector using the regular control pannel method
- then I opened a cmd window with admin rights and executed
"msiexec /x mysql-connector-net-6.5.3.msi /l*v logconnector.txt"
- a window was opened "are yous sure to remove the product"
- prepairing to remove
- this treatment is invalid for the actual installed products

- I reinstalled 6.4.4
- started the msi again from the shell window, with exactly the same result

- I will reinstall 6.4.4 again

Hope this helps,


[28 Feb 2012 21:32] Gabriela Martinez Sanchez
Louis, just double checking: currently you have installed the 6.4.4 and this is the one that is failing since as I understood, after you do that is not possible for you to install the 6.5.2 version. Am I correct?. If this is the case you must use the same msi (6.4.4) to run the msiexec command when trying to uninstall the 6.4.4 version. So this log is the one that would have the information of what is left over in the process. 

Thanks in advance!
[29 Feb 2012 7:46] Louis Breda van
Unistalllog when try to cli uninstall using mysql-connector-net-6.4.4.msi

Attachment: logconnector.txt (text/plain), 253.71 KiB.

[29 Feb 2012 7:51] Louis Breda van

I also tryed to uninstall using the 6.4.4 msi (log attached in the previeus replay) 

Note that that it not so likely that people do have a copy of the old msi, when installing a new one. However I have.

After doing this action, I tried to install using the 6.5.3.msi, which the same bad result. I will upload the 6.5.3 generated file (after the 6.4.4 msi remove) as well.


[29 Feb 2012 7:52] Louis Breda van
6.5.3.msi log after 6.4.4.msi "uninstall"

Attachment: logconnector.txt (text/plain), 13.93 KiB.

[29 Feb 2012 21:17] Gabriela Martinez Sanchez
Thanks Louis for submitting the logs. We're searching for the cause of this behavior, since its quite difficult to reproduce it, but we do want to know what the problem is. We'll keep you posted when we find the accurate solution.
[6 Mar 2012 21:01] Gabriela Martinez Sanchez
hi Louis I tried something that behaves very similar to the scenario that you described in your report. These are the steps: 1. I installed the library using "x" user 2. I logged off and log in with another user. 3. I tried to uninstall the connector and got the same error as your log (1605). The library looks like is not installed but if you try to install a newer it says that there is a previous version so you can't continue with the upgrade. The workaround is that you must uninstall the connector with the same user that you did the installation this way the library should be removed completely. And then you will be able to do the upgrade. 

Please let use know if this worked or if you have any comments or questions.

[7 Mar 2012 7:34] Louis Breda van

This is the problem area. I have been looking at "installed programs" logged in as normal user and logged in as admin. And could hardly believe my eyes

- normal user: 644 is installed (according to "installed programs" 
- admin user: 644 is not installed :(
- admin user: installed the ^missing 644^ 
- admin user: program is now in "installed programs" 
- admin user: remove 644 (you should not do that warning, other user logged in)
- normal user: logoff
- admin user: remove 644
- admin user: logoff
- normal user: login
- normal user: 644 still there
- normal user: remove 644 ==> Failed to ^install^ performance counters (-2147024894)

Botumline bizar, but still can not remove 644 correctly and as a concequence not install 6.5

But, we have some progress in regard to the problem direction, now the solution :>


[7 Mar 2012 8:32] Louis Breda van

After the "remove 644" test described before, I had severe problems with windows. For that reason I had to restore the windows partion. 

Luckely I had a very recent system partion image.

[3 Jun 2012 9:26] Louis Breda van

For info, I tried the following but still do not manage to get rid of 6.4.4
- removed visual studio 2008 express and every thing related
- installed studio ultimate 2012 release candidate
- tried to remove 6.4.4 again (seems to work, but does not work) and install 6.4.5
- tried to remove 6.4.5 and install 6.5.4 did not work at all

I still do not have any ideaa how to fix this. I can not even fix it by going back to an older system backup since I recent system backups do include the same problem.


[25 Sep 2013 15:36] Gabriela Martinez Sanchez
I wasn't able to reproduce the exact same scenario, only the one that I had already described. We have change the way Connector/Net is installed to prevent this kind of issues, so the recommendation is to use the 6.6.x version instead.
[6 Dec 2013 18:17] Michael Brady
Hate dredging up an old post but this is almost exactly my problem.

Tried to install an updated (5.6) MySQL. It all worked except the NET connector - said I have a 6.3 or later installed and have to uninstall it first. Except that as far as anything in the system is concerned no such thing exists. It's not in the Windows uninstall list, and after a thorough uninstall of all MySQL components using the MySQL installer (had to also download an old 5.5 installer so that would work - at least there was a message saying what was needed and where it was missing from) and Windows - and multiple restarts - I still can't install the current NET connector. Where is the "6.3 or later" connector if it's not anyplace that Windows can find it? The only previous connector I found before all the uninstalling was a 6.2.x (that also required downloading an old msi so it could uninstall).

As a side note, it's a real problem if I have to keep all of the old msi files in the original directory they were in when installed to support a future upgrade or uninstall. Nothing else I've used in years requires that.