Bug #75421 MySQL Workbench missing dependency on Fedora 21
Submitted: 6 Jan 2015 9:28 Modified: 3 Mar 2015 8:41
Reporter: Joe Borg Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.2.4 OS:Linux (Fedora 21)
Assigned to: CPU Architecture:Any
Tags: Fedora, workbench

[6 Jan 2015 9:28] Joe Borg
MySQL Workbench Fedora RPM will not install on Fedora 21.

How to repeat:
1) Get the Fedora RPM from http://dev.mysql.com/downloads/workbench/.
2) Try to install with either rpm -i or yum install
3) Both complain that libctemplate.so.2 is missing, even though it's installed (and devel).

Suggested fix:
Change the package manifest?
[8 Jan 2015 10:27] MySQL Verification Team
Hello Joe Borg,

Thank you for the report.
Download page http://dev.mysql.com/downloads/workbench/ list mysql-workbench-community-6.2.4-1.fc20.x86_64.rpm(Fedora20 rpm not Fed21)package only and which when tried complains about missing files.

[root@fedora21 Downloads]# rpm -ivh mysql-workbench-community-6.2.4-1.fc20.x86_64.rpm
error: Failed dependencies:
	libctemplate.so.2()(64bit) is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64
	libodbc.so.2()(64bit) is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64
	libodbcinst.so.2()(64bit) is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64
	libtinyxml.so.0()(64bit) is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64
	libvsqlitepp.so.3()(64bit) is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64
	libzip.so.2()(64bit) is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64
	proj is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64
	python-paramiko is needed by mysql-workbench-community-6.2.4-1.fc20.x86_64

[8 Jan 2015 10:31] MySQL Verification Team
[root@fedora21 Downloads]# yum localinstall mysql-workbench-community-6.2.4-1.fc20.x86_64.rpm 
Loaded plugins: langpacks
Examining mysql-workbench-community-6.2.4-1.fc20.x86_64.rpm: mysql-workbench-community-6.2.4-1.fc20.x86_64
Marking mysql-workbench-community-6.2.4-1.fc20.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package mysql-workbench-community.x86_64 0:6.2.4-1.fc20 will be installed
--> Processing Dependency: proj for package: mysql-workbench-community-6.2.4-1.fc20.x86_64
--> Processing Dependency: python-paramiko for package: mysql-workbench-community-6.2.4-1.fc20.x86_64
--> Processing Dependency: libctemplate.so.2()(64bit) for package: mysql-workbench-community-6.2.4-1.fc20.x86_64
--> Processing Dependency: libodbc.so.2()(64bit) for package: mysql-workbench-community-6.2.4-1.fc20.x86_64
--> Processing Dependency: libodbcinst.so.2()(64bit) for package: mysql-workbench-community-6.2.4-1.fc20.x86_64
--> Processing Dependency: libtinyxml.so.0()(64bit) for package: mysql-workbench-community-6.2.4-1.fc20.x86_64
--> Processing Dependency: libvsqlitepp.so.3()(64bit) for package: mysql-workbench-community-6.2.4-1.fc20.x86_64
--> Processing Dependency: libzip.so.2()(64bit) for package: mysql-workbench-community-6.2.4-1.fc20.x86_64
--> Running transaction check
---> Package ctemplate.x86_64 0:2.2-3.el7 will be installed
---> Package libzip.x86_64 0:0.11.2-3.fc21 will be installed
---> Package proj.x86_64 0:4.8.0-7.fc21 will be installed
---> Package python-paramiko.noarch 0:1.15.1-1.fc21 will be installed
--> Processing Dependency: python-crypto >= 2.1 for package: python-paramiko-1.15.1-1.fc21.noarch
--> Processing Dependency: python-ecdsa for package: python-paramiko-1.15.1-1.fc21.noarch
---> Package tinyxml.x86_64 0:2.6.2-6.fc21 will be installed
---> Package unixODBC.x86_64 0:2.3.2-6.fc21 will be installed
---> Package vsqlite++.x86_64 0:0.3.13-6.fc21 will be installed
--> Running transaction check
---> Package python-crypto.x86_64 0:2.6.1-6.fc21 will be installed
---> Package python-ecdsa.noarch 0:0.11-3.fc21 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

 Package                                     Arch                     Version                            Repository                                                        Size
 mysql-workbench-community                   x86_64                   6.2.4-1.fc20                       /mysql-workbench-community-6.2.4-1.fc20.x86_64                   106 M
Installing for dependencies:
 ctemplate                                   x86_64                   2.2-3.el7                          epel                                                             224 k
 libzip                                      x86_64                   0.11.2-3.fc21                      fedora                                                            64 k
 proj                                        x86_64                   4.8.0-7.fc21                       fedora                                                           186 k
 python-crypto                               x86_64                   2.6.1-6.fc21                       fedora                                                           467 k
 python-ecdsa                                noarch                   0.11-3.fc21                        fedora                                                            69 k
 python-paramiko                             noarch                   1.15.1-1.fc21                      fedora                                                           1.0 M
 tinyxml                                     x86_64                   2.6.2-6.fc21                       fedora                                                            53 k
 unixODBC                                    x86_64                   2.3.2-6.fc21                       fedora                                                           423 k
 vsqlite++                                   x86_64                   0.3.13-6.fc21                      fedora                                                            64 k

Transaction Summary
Install  1 Package (+9 Dependent packages)

Total size: 109 M
Total download size: 2.5 M
Installed size: 117 M
Is this ok [y/d/N]: y
Downloading packages:
(1/9): python-ecdsa-0.11-3.fc21.noarch.rpm                                                                                                               |  69 kB  00:00:07     
(2/9): libzip-0.11.2-3.fc21.x86_64.rpm                                                                                                                   |  64 kB  00:00:07     
(3/9): proj-4.8.0-7.fc21.x86_64.rpm                                                                                                                      | 186 kB  00:00:08     
(4/9): ctemplate-2.2-3.el7.x86_64.rpm                                                                                                                    | 224 kB  00:00:08     
(5/9): tinyxml-2.6.2-6.fc21.x86_64.rpm                                                                                                                   |  53 kB  00:00:00     
(6/9): unixODBC-2.3.2-6.fc21.x86_64.rpm                                                                                                                  | 423 kB  00:00:02     
(7/9): python-crypto-2.6.1-6.fc21.x86_64.rpm                                                                                                             | 467 kB  00:00:10     
(8/9): python-paramiko-1.15.1-1.fc21.noarch.rpm                                                                                                          | 1.0 MB  00:00:06     
(9/9): vsqlite++-0.3.13-6.fc21.x86_64.rpm                                                                                                                |  64 kB  00:00:07     
Total                                                                                                                                           157 kB/s | 2.5 MB  00:00:16     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
  Installing : proj-4.8.0-7.fc21.x86_64                                                                                                                                    1/10 

  Verifying  : mysql-workbench-community-6.2.4-1.fc20.x86_64                                                                                                              10/10 

  mysql-workbench-community.x86_64 0:6.2.4-1.fc20                                                                                                                               

Dependency Installed:
  ctemplate.x86_64 0:2.2-3.el7            libzip.x86_64 0:0.11.2-3.fc21  proj.x86_64 0:4.8.0-7.fc21      python-crypto.x86_64 0:2.6.1-6.fc21  python-ecdsa.noarch 0:0.11-3.fc21 
  python-paramiko.noarch 0:1.15.1-1.fc21  tinyxml.x86_64 0:2.6.2-6.fc21  unixODBC.x86_64 0:2.3.2-6.fc21  vsqlite++.x86_64 0:0.3.13-6.fc21    

[9 Jan 2015 8:41] Mike Lischke
Marked #75430 as duplicate of this one. The other one additionally discusses building from source, so this should be handled here too.
[9 Jan 2015 15:35] Alan Schmidt
Patch to make mysql-workbench-community compile with ctemplate 0.97 and newer

Attachment: ctemplate-0.97.patch (text/x-patch), 1.27 KiB.

[9 Jan 2015 15:42] Alan Schmidt
The "ReloadIfChanged" function in ctemplate was replaced with "ReloadAllIfChanged" for some reason in 2010.

The old function worked for a very long time, but it was finally removed in the version of ctemplate that ships with Fedora 21.

I managed to compile mysql-workbench under Fedora 21 with only the 3 changes in the patch file.
[12 Jan 2015 10:14] Joe Borg
Failure I get after patching

Attachment: failure_after_patch.log (text/x-log), 2.94 KiB.

[12 Jan 2015 10:14] Joe Borg
Hi Alan,

Thanks for the patch, after applying the patch, I get the attached errors (failure_after_patch.log).

[1 Feb 2015 19:13] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=75712 marked as duplicate of this one.
[3 Feb 2015 1:39] Philip Olson
Posted by developer:
Fixed as of the upcoming MySQL Workbench 6.2.5 release, and here's the changelog entry:

The Fedora RPM would not install on Fedora 21 due to missing ctemplate
dependencies. This is due to changes introduced in ctemplate version 0.97,
where the "ReloadIfChanged" function was replaced with

Thank you for the bug report.
[18 Feb 2015 9:44] MySQL Verification Team
Bug #75949 marked as duplicate of this
[3 Mar 2015 1:52] zhifeng hu
If you can not waiting oracle slowly release. you may download built rpm package to install it now.


If you need help. please leave message or comment.
[3 Mar 2015 8:41] Joe Borg
The RPM works perfectly.  Thanks guys!
[4 Mar 2015 4:45] zhifeng hu
Mysql workbench 6.2.5 released, so you can download from official now.