Bug #7403 error "Forcing close of thread 1 user: 'xxx'"
Submitted: 18 Dec 2004 13:24 Modified: 10 Jan 2013 10:59
Reporter: Victoria Reznichenko Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Windows Severity:S3 (Non-critical)
Version:4.0, 5.0.40, 5.1.42-bzr OS:Microsoft Windows (Windows)
Assigned to:
Triage: Triaged: D3 (Medium)

[18 Dec 2004 13:24] Victoria Reznichenko
Description:
On Windows if you have opened connections, you get the following errors during shutdown:

"Forcing close of thread 1  user: 'xxx'"

These errors are written to the error log only on Windows.

How to repeat:
1. connect to the MySQL server
2. shutdown it
[14 Jul 2005 18:55] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/internals/27091
[15 Jul 2005 20:01] Reggie Burnett
Fixed in 4.1.14 and 5.0.10
[16 Jul 2005 10:22] Konstantin Osipov
The fix for the bug forces safe_mutex assertion failure in 5.0.
The bug needs a better fix, at least in 5.0.
[18 Jul 2005 18:26] Reggie Burnett
Marked back as documenting.  Guilhem created a new bug report for the fix and will be pushing a fix for it.
[18 Jul 2005 19:28] Paul Dubois
Noted in 4.1.14, 5.0.10 changelogs.
[19 Nov 2009 18:00] Valerii Kravchuk
Bug #48879 is marked as a duplicate of this one.
[19 Dec 2009 7:44] Jon Stephens
4.1/5.0 changelog entries removed at request of Support, since there is no evidence that this bug was ever actually fixed:

http://lists.mysql.com/commits/95035

Left bug status unchanged.
[19 Dec 2009 7:45] Paul Dubois
The bug has not yet been fixed. I disabled the changelog entry until such time as it is.
[19 Dec 2009 7:46] Paul Dubois
Oops, Jon beat me to it.
[5 Feb 2010 13:51] Shane Bester
workaround, set in my.ini: log_warnings=0
[10 Jan 2013 10:59] Erlend Dahl
We wont't fix this because:

a)This is an old bug, no blocked customer.

b)Removing the warning is simple, removing the reason why warning is occurring is hard.