Bug #48879 Forcing close of thread ..... user: xxx
Submitted: 18 Nov 2009 20:05 Modified: 19 Nov 2009 17:59
Reporter: Oguzhan Salmaner Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Windows Severity:S1 (Critical)
Version:5.1.40 OS:Microsoft Windows (Server 2003 Enterprise Edition Service Pack 2, .NET Framework 3.5 SP1)
Assigned to: CPU Architecture:Any

[18 Nov 2009 20:05] Oguzhan Salmaner
Description:
When i enter my site, i got

Forcing close of thread ..... user: xxx

this error and my site is down untill restarting mysql, after a few day investigation i found the same error and a pach for this but its all happend in 2005. Is there no one else taking this eror or i am the only one?

How to repeat:
1. connect to the MySQL server
2. shutdown it

Suggested fix:
İ found this http://lists.mysql.com/internals/27091 , but i cant compilie and run mysql
[18 Nov 2009 21:14] MySQL Verification Team
Thank you for the bug report. When you perform the shutdown there are clients connected with the server?. If yes then the message is the correct behavior. Thanks in advance.
[18 Nov 2009 22:21] Oguzhan Salmaner
Yes 2 user are working at the same time withour the problem user, this is the log file

091118 21:48:18 [Note] Plugin 'FEDERATED' is disabled.
091118 21:48:19  InnoDB: Started; log sequence number 0 44233
091118 21:48:19 [Note] Event Scheduler: Loaded 0 events
091118 21:48:19 [Note] D:\MySQL\bin\mysqld: ready for connections.
Version: '5.1.40-community'  socket: ''  port: 3306  MySQL Community Server (GPL)
091118 22:15:06 [Note] D:\MySQL\bin\mysqld: Normal shutdown

091118 22:15:06 [Note] Event Scheduler: Purging the queue. 0 events
091118 22:15:08 [Warning] D:\MySQL\bin\mysqld: Forcing close of thread 128  user: 'zzz'

091118 22:15:08 [Warning] D:\MySQL\bin\mysqld: Forcing close of thread 123  user: 'zzz'

091118 22:15:08 [Warning] D:\MySQL\bin\mysqld: Forcing close of thread 116  user: 'xxx'

091118 22:15:08 [Warning] D:\MySQL\bin\mysqld: Forcing close of thread 109  user: 'yyy'

091118 22:15:08 [Warning] D:\MySQL\bin\mysqld: Forcing close of thread 99  user: 'yyy'

091118 22:15:08 [Warning] D:\MySQL\bin\mysqld: Forcing close of thread 72  user: 'yyy'

091118 22:15:08  InnoDB: Starting shutdown...
091118 22:15:08  InnoDB: Shutdown completed; log sequence number 0 44233
091118 22:15:08 [Note] D:\MySQL\bin\mysqld: Shutdown complete

the zzz user cause problem, how can i fix it? it send a very very long querys at the same time
[19 Nov 2009 17:59] Valeriy Kravchuk
So, this is a duplicate of bug #7403 that had that patch you mentioned once in the past, but is still "Verified". I do not see the patch applied even to the latest 5.1.42.
[8 Dec 2009 16:01] Vladislav Vaintroub
Oguzhan, this is a warning , not error.  This warning is written when someone shuts down mysql but it is not the reason for shutdown.
[19 Dec 2009 0:46] Roel Van de Paar
Oguzhan, FYI - you should not use patch 27091. It was never released and will likely cause other issues.