Bug #72379 Show all the User-Defined Variables
Submitted: 18 Apr 2014 11:42 Modified: 18 Apr 2014 18:23
Reporter: Isaacs Isaacs Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.6 OS:Mac OS X
Assigned to:

[18 Apr 2014 11:42] Isaacs Isaacs
Description:
 Show all the  User-Defined Variables . Cause no one can remeber all the  User-Defined Variables's name they had made .

How to repeat:
set @a_var = 'value1' , @b_var = 'valueb' ;

Zzzzz... (one hour has been gone)

Now, do you remember you have set the 'a_var' and 'b_var' ??? Of course you don't.

Suggested fix:
just like 'show session variables' , make this command work 'show user variables'.
[18 Apr 2014 18:23] Umesh Shastry
Hello Isaacs,

Thank you for the feature request.
Duplicate of Bug #20307

Thanks,
Umesh