Bug #20307 Request SHOW command support for User-Defined Variables
Submitted: 7 Jun 2006 5:00 Modified: 8 Aug 8:12
Reporter: J B Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Performance Schema Severity:S4 (Feature request)
Version:5 OS:Linux (linux\win)
Assigned to: Marc Alff
Triage: Triaged: D5 (Feature request)

[7 Jun 2006 5:00] J B
Description:
As above, something like:

SHOW user_variables

would be handy.

How to repeat:
SHOW user_variables
[13 Jun 2006 10:22] Valerii Kravchuk
Thank you for a reasonable feature request.
[27 Jul 2008 3:24] Daniel Bramblett
Hi,  I second this request.  Tonight this kind of functionality would have been very handy to have and saved me some heartburn in my development. I have quite a few user defined variables and being able to see their values with one command at any given moment would have been useful. Thanks -Daniel
[3 Sep 2010 3:57] Valerii Kravchuk
Bug #56520 was marked as a duplicate of this one.
[26 Sep 2012 11:25] Nathan Aschoff
I second this request, which has been pending for 6 years. ;)
[18 Apr 2014 18:24] Umesh Shastry
Bug #72379 marked as duplicate of this..
[7 Aug 19:47] Valerii Kravchuk
This is already implemented at least in 5.7+ in Performance Schema, see https://dev.mysql.com/doc/refman/5.7/en/performance-schema-user-variable-tables.html
[8 Aug 8:12] Marc Alff
Implemented in 5.7.5.