Bug #70338 autocomplete popup window freezes on screen
Submitted: 13 Sep 2013 16:32 Modified: 15 Sep 2014 23:38
Reporter: Orlando Betancourth Alvarenga Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S2 (Serious)
Version:6.0.7 OS:Mac OS X
Assigned to: CPU Architecture:Any
Tags: autocomplete

[13 Sep 2013 16:32] Orlando Betancourth Alvarenga
Description:
Using a big schema database, >1000 tables. When writing a simple query and autocomplete toogles but not used it just freezes on screen, if you try to scroll on the freezed window workbench will just closes up.

How to repeat:
ON MAC mountain Lion latested update until 20130913 on mac book pro. Workbench 6.0.7, in query tab editor using a big schema (>1000 tables) writing a simple select  query when autocomplete shows up just keep writing, if autcomplete window freezes scroll over to close workbench.
[13 Sep 2013 20:56] Umesh Shastry
Hello Orlando,

Thank you for the bug report.
Verified as described.

Thanks,
Umesh
[13 Sep 2013 21:00] Umesh Shastry
// How to repeat:

// Tried with WB 6.0.7, MySQL version 5.6.13 on OL6

mysql> use test
Database changed
mysql> 
mysql> DELIMITER //
mysql> DROP PROCEDURE IF EXISTS ct//
Query OK, 0 rows affected, 1 warning (0.00 sec)

mysql> CREATE PROCEDURE ct()
    -> BEGIN
    -> 
    ->  DECLARE v1 INT DEFAULT 5010;
    ->   WHILE v1 > 0 DO
    -> 
    -> SET @s = CONCAT('DROP TABLE IF EXISTS ', 't',v1);
    -> PREPARE stm FROM @s;
    -> EXECUTE stm;
    -> 
    -> SET @s = CONCAT('CREATE TABLE ','t',v1,' (id int not null)');
    -> PREPARE stm FROM @s;
    -> EXECUTE stm;
    -> 
    ->     SET v1 = v1 - 1;
    ->   END WHILE;
    -> 
    -> 
    -> END //
Query OK, 0 rows affected (0.00 sec)

mysql> DELIMITER ;
mysql> call ct;

^^^Used above SP to create dummy tables(5k) and when table creation was running in the background, used WB and tried to use auto complete feature and WB freezed and had to kill WB session...
[2 Feb 2014 4:10] Puneet Sharma
Has this been fixed? I can see still see the issue in my workbench version
[6 Feb 2014 12:02] Umesh Shastry
Bug #67553 Marked as duplicate of this
[15 Feb 2014 21:30] Jason Hinkle
I get this a lot and can't figure out how to intentionally reproduce it, but I do know that the situation occurs when typing quickly and ignoring the auto-complete dialogs.

I can reproduce an odd variation of this, though.  Type in the query window until an auto-complete dialog appears.  Then tab away from the app to another app.  The workbench dialog window will persist on top of all other application windows even though mysql workbench is no longer active.
[15 Feb 2014 21:30] Jason Hinkle
auto-complete dialog appearing when workbench is not the active window

Attachment: Screen Shot 2014-02-15 at 3.27.51 PM.png (image/png, text), 146.40 KiB.

[14 Apr 2014 8:00] Valentin Dosev
has this been fixed - it happens quite often to me
[15 Sep 2014 18:52] Johannes Taxacher
Posted by developer:
 
fix verified in 6.2.3
[15 Sep 2014 23:38] Philip Olson
Fixed as of the upcoming MySQL Workbench 6.2.3 release, and here's the changelog entry:

In the SQL editor, code completion would freeze MySQL Workbench when used with
a large (1000+ tables) database.

Thank you for the bug report.