Bug #70262 Workbench 6 crashes down while starting up
Submitted: 6 Sep 2013 13:37 Modified: 6 Nov 2013 19:35
Reporter: Carlos Teevin Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.0.7 OS:Microsoft Windows (Ultimate 64 bits)
Assigned to: CPU Architecture:Any
Tags: exception, External Component, workbench 6
Triage: Needs Triage: D1 (Critical)

[6 Sep 2013 13:37] Carlos Teevin
Description:
Please help me finding out the solution for this problem...
Right after executing "MySQL Workbench 6.0.7 CE\MySQLWorkbench.exe" a similar message to this appears:
MySQL Workbenchs has encountered a problem
External component has thrown an exception
We are sorry for the inconvenience...

After that there is no way to continue using the application

How to repeat:
By executing "MySQL Workbench 6.0.7 CE\MySQLWorkbench.exe" directly, or trying to start MySQL Workbench through any other way

Suggested fix:
I tried anything, this problem only happens with this computer, any other computer I usually work with has no problem with this new version. But this is the main one :(
[6 Sep 2013 13:46] Carlos Teevin
Workbench log with errors found

Attachment: wb.log (text/plain), 9.80 KiB.

[6 Sep 2013 16:20] Carlos Teevin
Ok guys, no need to answer my post, the problem is fixed, I just renamed the folder 
"C:\Users\yourUsername\AppData\Roaming\MySQL\Workbench" that was previously created by an earlier used version (recommended on previous post).

Anyway, it is a bug and you should consider it for next version, cheers.
[10 Sep 2013 11:22] Miguel Solorzano
Thank you for the feedback. Which prior version you have installed before upgrade to 6.0.7?. Thanks.
[26 Sep 2013 2:30] Miguel Solorzano
Thank you for the bug report.
[28 Sep 2013 23:11] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=70457 duplicate of this one.
[29 Sep 2013 15:33] Vinicius Oliveira Vinicius
Thanks. Works!
[8 Oct 2013 17:13] Steve Burrus
I am sorry but I am still getting that error about the "External Exception" when I try to open up Workbench 6.0.7 even after following Carlos Teevin's advice about putting the instasllation into that path of "C:\Users\[UserName]\AppData\Roaming\MYSQL\Workbench\"!! Can someone please help me with this?
[10 Oct 2013 11:56] Alfredo Kojima
Hi please start WB with the -log-level=debug3 cmdline option and send the wb.log file generated afterwards.
[10 Oct 2013 13:45] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=70584 duplicate of this one.
[10 Oct 2013 18:21] Alfredo Kojima
If anyone can get this crash fixed by renaming the AppData folder, pls attach a zip of the offending folder here, so we can try repeating.
[16 Oct 2013 12:23] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=70636 duplicate of this one.
[16 Oct 2013 19:43] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=70638 duplicate of this one.
[16 Oct 2013 21:18] Steve Burrus
alfredo here is the "dump" from trying to install mysql 5.6 with Workbench 6.0.

Windows ® Installer. V 5.0.7601.17514 

msiexec /Option <Required Parameter> [Optional Parameter]

Install Options
	</package | /i> <Product.msi>
		Installs or configures a product
	/a <Product.msi>
		Administrative install - Installs a product on the network
	/j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
		Advertises a product - m to all users, u to current user
	</uninstall | /x> <Product.msi | ProductCode>
		Uninstalls the product
Display Options
	/quiet
		Quiet mode, no user interaction
	/passive
		Unattended mode - progress bar only
	/q[n|b|r|f]
		Sets user interface level
		n - No UI
		b - Basic UI
		r - Reduced UI
		f - Full UI (default)
	/help
		Help information
Restart Options
	/norestart
		Do not restart after the installation is complete
	/promptrestart
		Prompts the user for restart if necessary
	/forcerestart
		Always restart the computer after installation
Logging Options
	/l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>
		i - Status messages
		w - Nonfatal warnings
		e - All error messages
		a - Start up of actions
		r - Action-specific records
		u - User requests
		c - Initial UI parameters
		m - Out-of-memory or fatal exit information
		o - Out-of-disk-space messages
		p - Terminal properties
		v - Verbose output
		x - Extra debugging information
		+ - Append to existing log file
		! - Flush each line to the log
		* - Log all information, except for v and x options
	/log <LogFile>
		Equivalent of /l* <LogFile>
Update Options
	/update <Update1.msp>[;Update2.msp]
		Applies update(s)
	/uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
		Remove update(s) for a product
Repair Options
	/f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
		Repairs a product
		p - only if file is missing
		o - if file is missing or an older version is installed (default)
		e - if file is missing or an equal or older version is installed
		d - if file is missing or a different version is installed
		c - if file is missing or checksum does not match the calculated value
		a - forces all files to be reinstalled
		u - all required user-specific registry entries (default)
		m - all required computer-specific registry entries (default)
		s - all existing shortcuts (default)
		v - runs from source and recaches local package
Setting Public Properties
	[PROPERTY=PropertyValue]

Consult the Windows ® Installer SDK for additional documentation on the
command line syntax.

Copyright © Microsoft Corporation. All rights reserved.Portions of this software are based in part on the work of the Independent JPEG Group.
[21 Oct 2013 13:47] Bruce Peoples
I too have gotten "MySQL Workbenchs has encountered a problem
External component has thrown an exception
We are sorry for the inconvenience..."  I have been using he workbench for 2 days....then this error.  I looked for the C:\Users\username\appdta\....could not find the app data folder.  There is an AppData folder at C:\Users but does not contain any of the sub-folders - files as described in the other fix...any help would be appreciated...
[21 Oct 2013 14:05] Bruce Peoples
Figured it out.  I saved off a "new" .sql file while in Workbench. I exited Workbench.  When launched again is when I got the error.  For some reason I looked at the folder I saved the .sql file in and noticed it was 0kb in size.  I deleted this file and re-launched Workbench ... it launched normally.
[21 Oct 2013 15:30] Steve Burrus
Well Bruce Peoples I cannot efven get into Workbench 6.0.7!! So how did you initially install WB successfully anyway? I think that my problem is due to some missing dll files but don't know which files exactly.
[1 Nov 2013 23:12] Jonathan Gonzalez
Thanks Bruce People you are a genius!!!! ^.^
[3 Nov 2013 23:44] Matt Govaert
You the man, Bruce! Your resolution worked for me as well. Deleted 0k files in the SQL folder and I'm good to go!
[6 Nov 2013 10:56] Steven Wohlleben
Thanks Bruce! Safed my day...
[6 Nov 2013 19:35] Philip Olson
Fixed as of MySQL Workbench 6.0.8, and here's the changelog entry:

On Microsoft Windows, having an empty SQL file saved in the AppData path
would cause MySQL Workbench to not start. 

A workaround was to delete the empty SQL file before starting MySQL Workbench.

Thank you for the bug report.
[7 Nov 2013 15:25] Jan van den Berg
Hello, I'm new to mySQL and I'm wondering where these mentioned 0kB files are located on my system that causes MySQL Workbench 6.0.7 to crash. I don't have any 0kB files in my personal AppData submaps.
[7 Nov 2013 15:32] Jan van den Berg
Yeah, I've got them and it works again, Thanx a lot
[7 Nov 2013 16:03] Luis Fernando juarez Torres
Thank you very much for the information, It really works again!!
[14 Sep 2016 14:09] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=82993 marked as duplicate of this one.
[17 Oct 2016 11:39] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=83392 marked as duplicate of this one.
[1 Feb 2017 12:22] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=84738  marked as duplicate of this one.
[24 Sep 2017 11:38] Álvaro Pino Castillo
same problem, it gives the bug errror when i try to enter to my code ignitier database
[31 May 2018 11:50] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=70262 marked as duplicate of this one.