Bug #69399 Inconsistency in crash report
Submitted: 4 Jun 2013 17:21 Modified: 5 Jun 2013 12:50
Reporter: Valeriy Kravchuk Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Errors Severity:S3 (Non-critical)
Version:5.5.x, 5.6.x OS:Any
Assigned to: CPU Architecture:Any
Tags: crash, error, UTC

[4 Jun 2013 17:21] Valeriy Kravchuk
Description:
In case of crashes time reported in one place in the error log is inconsistent with others. UTC is used for a message about signal, while local time is used in other messages, like this:

00:41:38 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

key_buffer_size=402653184
read_buffer_size=2097152
max_used_connections=30
max_threads=151
thread_count=30
connection_count=30
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 1013437 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x268bbc0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7f460720ce48 thread_stack 0x40000
/usr/local/mysql/bin/mysqld(my_print_stacktrace+0x35)[0x79ffa5]
/usr/local/mysql/bin/mysqld(handle_fatal_signal+0x403)[0x66f5a3]
/lib/x86_64-linux-gnu/libpthread.so.0(+0xfc60)[0x7f4606e70c60]
/usr/local/mysql/bin/mysqld(_ZN12ha_federated7rnd_posEPhS0_+0x38)[0x7ffab8]
/usr/local/mysql/bin/mysqld(_ZN12multi_update10do_updatesEv+0x409)[0x5e5a79]
/usr/local/mysql/bin/mysqld(_ZN12multi_update8send_eofEv+0x2a8)[0x5e5f48]
/usr/local/mysql/bin/mysqld[0x5a079e]
/usr/local/mysql/bin/mysqld(_ZN4JOIN4execEv+0x8ea)[0x5b480a]
/usr/local/mysql/bin/mysqld(_Z12mysql_selectP3THDPPP4ItemP10TABLE_LISTjR4ListIS1_ES2_jP8st_orderSB_S2_SB_yP13select_resultP18st_select_lex_unitP13st_select_lex+0x1c3)[0x5b0593]
/usr/local/mysql/bin/mysqld(_Z18mysql_multi_updateP3THDP10TABLE_LISTP4ListI4ItemES6_PS4_y15enum_duplicatesbP18st_select_lex_unitP13st_select_lexPP12multi_update+0x121)[0x5e48c1]
/usr/local/mysql/bin/mysqld(_Z21mysql_execute_commandP3THD+0x3018)[0x57a4b8]
/usr/local/mysql/bin/mysqld(_Z11mysql_parseP3THDPcjP12Parser_state+0x18a)[0x57bcea]
/usr/local/mysql/bin/mysqld(_Z16dispatch_command19enum_server_commandP3THDPcj+0x1331)[0x57d8a1]
/usr/local/mysql/bin/mysqld(_Z24do_handle_one_connectionP3THD+0x167)[0x6146e7]
/usr/local/mysql/bin/mysqld(handle_one_connection+0x54)[0x614754]
/usr/local/mysql/bin/mysqld(pfs_spawn_thread+0x5b)[0x7fdddb]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x6d8c)[0x7f4606e67d8c]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d)[0x7f46060e5fdd]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (26969b0): UPDATE t1 JOIN t1fed ON t1.id = t1fed.id SET t1fed.message = t1.message
Connection ID (thread ID): 40
Status: NOT_KILLED

The manual page at http://dev.mysql.com/doc/mysql/en/crashing.html contains
information that should help you find out what is causing the crash.
130212 19:41:38 mysqld_safe Number of processes running now: 0
130212 19:41:38 mysqld_safe mysqld restarted

(this is from my favorite bug #68354). Note this:

00:41:38 UTC - mysqld got signal 11 ;

and compare to other messages:

130212 19:41:38 mysqld_safe Number of processes running now: 0
130212 19:41:38 mysqld_safe mysqld restarted

It's UTC (and only time) vs local date and time in timestamp.

How to repeat:
Crash any version of MySQL server and check. Use test case from bug #68354 if in doubts on how to crash MySQL...

Suggested fix:
Use consistent format all over the error log? Print UTC time upon server startup as additional message if you consider this essential.
[4 Jun 2013 17:54] Shane Bester
Likely not a bug.  The thing is, signal handler must use approved safe functions or risk causing a crash itself... "time()" is safe but returns UTC.  Do you have a suggestion what can be used in its place?

http://bugs.mysql.com/bug.php?id=54082 for details.
[5 Jun 2013 12:50] Shane Bester
This behavior is intentional and will not be changed. 
Functions called from signal handlers must be async signal safe...

http://docs.oracle.com/cd/E19455-01/806-5257/gen-26/index.html