Bug #69224 Generic error in GDI+ when using autorefresh
Submitted: 14 May 2013 8:34 Modified: 14 Aug 2013 11:15
Reporter: Justinas Urbanavičius Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S3 (Non-critical)
Version:5.2.47 r10398 OS:Microsoft Windows (8 x64)
Assigned to: CPU Architecture:Any
Tags: GDI generic error auto refresh

[14 May 2013 8:34] Justinas Urbanavičius
Description:
11:22:35 [INF][      Workbench]: UI is up
11:22:36 [INF][      Workbench]: Running the application
11:22:38 [INF][wb_admin_ssh.py]: SSH: Connected via ssh to phpdev.in.telecom.lt
11:22:38 [INF][     SSH tunnel]: Starting tunnel
11:22:38 [INF][wb_admin_control.py]: Created SQL connection to MySQL server. Server version is (5, 1, 4), conn status = True, active plugins = set([])
11:22:38 [INF][wb_admin_grt.py]: AdministratorTab: Server version (5, 1, 4) is supported
11:22:38 [INF][            WBA]: Initializing extension modules for WBA...
11:22:38 [INF][            WBA]: 0 extension modules initialized
11:22:38 [INF][wb_admin_grt.py]: do_open_administrator(): Completed
11:22:39 [INF][wb_admin_control.py]: Created SQL connection to MySQL server. Server version is (5, 1, 4), conn status = True, active plugins = set([])
11:22:53 [ERR][      Workbench]: A generic error occurred in GDI+.
Exception = System.Runtime.InteropServices.ExternalException
Message = A generic error occurred in GDI+.
FullText = System.Runtime.InteropServices.ExternalException (0x80004005): A generic error occurred in GDI+.
   at System.Drawing.Graphics.CheckErrorStatus(Int32 status)
   at System.Drawing.Graphics.DrawString(String s, Font font, Brush brush, RectangleF layoutRectangle, StringFormat format)
   at Aga.Controls.Tree.NodeControls.BaseTextControl.Draw(TreeNodeAdv node, DrawContext context)
   at Aga.Controls.Tree.TreeViewAdv.DrawNode(TreeNodeAdv node, DrawContext context)
   at Aga.Controls.Tree.TreeViewAdv.DrawRow(PaintEventArgs e, DrawContext& context, Int32 row, Rectangle rowRect)
   at Aga.Controls.Tree.TreeViewAdv.OnPaint(PaintEventArgs e)
   at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
   at System.Windows.Forms.Control.WmPaint(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
11:23:09 [INF][ mforms backend]: Shutting down mforms backend
11:23:09 [INF][      Workbench]: Shutting down Workbench
11:23:10 [INF][ mforms managed]: Shutting down mforms wrapper
11:23:10 [INF][      Workbench]: Done

How to repeat:
Open DB server adminsitrator > Server Status > Connections 

Select Refresh Rate : 1 second 
Wait for refresh. Connections pane gets a red cross and GDI crashes
[14 May 2013 11:47] Miguel Solorzano
Thank you for the bug report. I couldn't repeat connected locally with a server 5.6.11 on Windows 8 and Windows 7. Please describe your connection and server. Thanks.
[14 May 2013 11:52] Justinas Urbanavičius
MySQL Server:
mysql  Ver 14.14 Distrib 5.1.49, for debian-linux-gnu (x86_64) using readline 6.1

Mysql server runs on remote machine, OS Linux Debian 2.6.32-5-amd64
Remote management: SSH login based management
[14 May 2013 14:19] Miguel Solorzano
SSH connection test

Attachment: server_status.png (image/png, text), 44.04 KiB.

[14 May 2013 14:21] Miguel Solorzano
I can repeat connecting with ssl with server 5.1 running on Centos 6.3 (see prior attached screen-shot).
[14 May 2013 15:57] Justinas Urbanavičius
from screenshot i can see that load and memory are not monitore. mine are.
When creating connection i selected:
1. Remote Host -> Address: my intranet server -> Next
2. Connection Method: Standard TCP/IP -> Next
3. Entered password...
Get Server version 5.1.49-3
Get Server OS: Linux
4. SSH login based management ->
Operating System: Linux
Mysql isntallation Type: Ubuntu Linux (Mysql package)
-> Next
... Finish.

last time it crashed i was dumping 800MB database from one server and importing it into the one that was monitored. Tried it just now and it also crashed.
Maybe the graphs can't handle a spike in monitoring data. Attached screenshots.
[14 May 2013 15:58] Justinas Urbanavičius
Server status without refresh

Attachment: workbench-dont-refresh.PNG (image/png, text), 54.52 KiB.

[14 May 2013 15:59] Justinas Urbanavičius
Server status after import start and crash

Attachment: workbench-refresh.PNG (image/png, text), 99.91 KiB.

[14 May 2013 21:12] Miguel Solorzano
Please describe how you did the dumping and import process. Thanks.
[15 May 2013 5:25] Justinas Urbanavičius
i just do:
mysqldump.exe --quick --default-character-set=utf8 --skip-lock-tables --max-allowed-packet=128M -h${src.db.server} -u${src.db.user} -p${src.db.pass} -q ${src.db.name} | mysql.exe --default-character-set=utf8 -h${dst.db.server} -u${dst.db.user} -p${dst.db.pass} -q -B ${dst.db.name}

the data is dumped form one linux server and immediately piped to another described earlier linux server, the middle server that does the work is Windows Server 2008 R2 x64.
[11 Jul 2013 23:49] Alfredo Kojima
How big was the loaded script?
[12 Jul 2013 5:35] Justinas Urbanavičius
It was a dump file actually, about 1.2G.
152 tables, 2205000 rows across all tables
[7 Aug 2013 0:35] Alfredo Kojima
Did the data being imported include blobs or non-ascii characters?
I've tried repeating with a dump being imported continually for an hour, but I still don't get this error.
[7 Aug 2013 6:42] Justinas Urbanavičius
Dumps include mostly strings, of TEXT, some of LONGTEXT. Strings are in utf8 using utf8_general_ci collation, with Lithuanian characters:
ąčęėįšųūž

Don't know if this is related, but workbench is running on windows server that i connect through RDP. GDI as I understand is related to graphics, and RDP could be related to that.
[7 Aug 2013 18:48] Alfredo Kojima
This is a duplicate of bug #68146
Please upgrade to version 6.0.5 or newer
[7 Aug 2013 19:03] Justinas Urbanavičius
How is this duplicate of some migration bug?

they aren't even related :) I don't migrate anything, and don't use migration feature, the window that lists queries just stops redrawing and crashes
[14 Aug 2013 11:15] Justinas Urbanavičius
Problem i'm experiencing, seems to be resolved in v6.0.6.11184, so maybe it can be closed.