Bug #67599 Tried to exit workbench after it had been idle for 15+ hours
Submitted: 15 Nov 2012 17:53 Modified: 16 Nov 2012 14:51
Reporter: Gordon Cooper Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.44 OS:Microsoft Windows (Microsoft Windows XP Professional Service Pack 3 (build 2600))
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[15 Nov 2012 17:53] Gordon Cooper
Description:
Left workbench up over night and when I went to close it this morining got a clipboard error. "Requested Clipboard operation did not succeed.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.44  revision 9933
Configuration Directory: C:\Documents and Settings\cooperg\Application Data\MySQL\Workbench
Data Directory: C:\MySQL5\MySQL Workbench CE 5.2.44
Cairo Version: 1.8.8
OS: Microsoft Windows XP Professional Service Pack 3 (build 2600)
CPU: 2x AMD Athlon(tm) 64 X2 Dual Core Processor 3800+, 1.9 GiB RAM
Active video adapter (0): ATI Radeon Xpress 1150
Installed video RAM: 128 MB
Current video mode: 1440 x 900 x 4294967296 colors
Used bit depth: 32
Driver version: 6.14.10.6925
Installed display drivers: ati2dvag.dll
Current user language: English (United States)

Exception = System.Runtime.InteropServices.ExternalException
Message = Requested Clipboard operation did not succeed.
FullText = System.Runtime.InteropServices.ExternalException (0x800401D0): Requested Clipboard operation did not succeed.
   at System.Windows.Forms.Clipboard.ThrowIfFailed(Int32 hr)
   at System.Windows.Forms.Clipboard.GetDataObject(Int32 retryTimes, Int32 retryDelay)
   at System.Windows.Forms.Clipboard.GetDataObject()
   at System.Windows.Forms.Clipboard.ContainsText(TextDataFormat format)
   at System.Windows.Forms.Clipboard.ContainsText()
   at MySQL.Forms.ScintillaControl.get_CanPaste()
   at MySQL.GUI.Workbench.MainForm.EditCanPaste()
   at MySQL.Grt.RunWrappedDelegate0<bool\,bool\,MySQL::Grt::DelegateSlot0<bool\,bool>::ManagedDelegate>.native_callback()
   at boost.detail.function.function_invoker0<bool (__cdecl*)(void),bool>.invoke(function_buffer* function_ptr)
   at base.NotificationCenter.send(NotificationCenter* , basic_string<char\,std::char_traits<char>\,std::allocator<char> >* , Void* )
   at MySQL.Workbench.ManagedNotificationCenter.Send(String notification, IntPtr sender)
   at MySQL.GUI.Workbench.MainForm.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Unknown.
[16 Nov 2012 14:51] Miguel Solorzano
duplicate of http://bugs.mysql.com/bug.php?id=65836 . Thanks.