Bug #66383 I got this bug when I am trying to edit the table which I am designing
Submitted: 14 Aug 2012 16:44 Modified: 14 Aug 2012 16:49
Reporter: Durga Kokkonda Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[14 Aug 2012 16:44] Durga Kokkonda
Description:
I got this bug when I am trying to edit the table which I am designing

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9724
Configuration Directory: C:\Users\udkokk\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.41
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: 2x Intel(R) Core(TM)2 CPU          6400  @ 2.13GHz, 2.0 GiB RAM
Active video adapter (0): Radeon X1600 Series (Microsoft Corporation - WDDM) 
Installed video RAM: 256 MB
Current video mode: 1680 x 1050 x 4294967296 colors
Used bit depth: 32
Driver version: 8.56.1.16
Installed display drivers: atiumdag,atiumdva,atiumd64.dll,atiumd6a.cap,atitmm64
Current user language: English (United States)

Exception = System.InvalidCastException
Message = Unable to cast object of type 'MySQL.Forms.MenuItemImpl' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Unable to cast object of type 'MySQL.Forms.MenuItemImpl' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   at MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   at MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   at MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   at boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   at wb.WBContext.flush_idle_tasks(WBContext* )
   at MySQL.Workbench.WbContext.flush_idle_tasks()
   at MySQL.GUI.Workbench.Program.timer_Tick(Object sender, EventArgs e)

How to repeat:
Select the new table which is developed with some columns, and save it when trying to edit the columns by going to menu item EDIT and selecting option to edit the existing table then this Error popped up with message "Workbench has encountered a problem" unable to cast object of type "MySQL.Forms.MenuItemImpl' to type MySQL.GUI.Workbench.Plugins.DOckablePlugin
[14 Aug 2012 16:49] Alfredo Kojima
Please try version 5.2.42
This is a duplicate of bug #66013