Bug #66324 Application crashes always when I writing Inserts or Foreign Keys.
Submitted: 11 Aug 2012 8:59 Modified: 11 Aug 2012 9:50
Reporter: Alexander Runkevich Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S1 (Critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[11 Aug 2012 8:59] Alexander Runkevich
Description:
I have two monitors. This error is on my work and home computers.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\alexander.runkevich\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: 4x Intel(R) Core(TM) i3 CPU         540  @ 3.07GHz, 7.9 GiB RAM
Active video adapter (0): NVIDIA GeForce GTS 250
Installed video RAM: 1024 MB
Current video mode: 1920 x 1080 x 4294967296 colors
Used bit depth: 32
Driver version: 8.17.12.6724
Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Current user language: Украинский (Украина)

Exception = System.InvalidCastException
Message = Не удалось привести тип объекта "MySQL.Grt.Db.MySQLTableEditorBE" к типу "MySQL.GUI.Workbench.Plugins.DockablePlugin".
FullText = System.InvalidCastException: Не удалось привести тип объекта "MySQL.Grt.Db.MySQLTableEditorBE" к типу "MySQL.GUI.Workbench.Plugins.DockablePlugin".
   в MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   в MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   в MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   в boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   в wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   в MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   в MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   в System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   в MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   в System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   в System.Windows.Forms.Control.WndProc(Message& m)
   в System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   в System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   в System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   в System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Open app;
Open table to edit;
Edit Inserts or Foreign Keys;
Double click on another table to open for edit;
No results, table is not opened;
After ~5-7 seconds app show Bug Report form;
[11 Aug 2012 9:50] Valeriy Kravchuk
This is a duplicate of bug #66013.