Bug #66275 Cannot open editor window for table in EER Diagram
Submitted: 9 Aug 2012 10:52 Modified: 9 Aug 2012 11:16
Reporter: Oleg L Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Home Basic Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Aug 2012 10:52] Oleg L
Description:
After editing a table in EER Diagram cannot open this table's editor for next time!

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\Lenovo\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Home Basic Edition Service Pack 1 (build 7601), 64-bit
CPU: 4x Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz, 7.9 GiB RAM
Active video adapter (1): NVIDIA GeForce 410M 
Installed video RAM: 1024 MB
Current video mode: 1366 x 768 x 4294967296 colors
Used bit depth: 32
Driver version: 8.17.12.6753
Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Current user language: Русский (Россия)

Exception = System.InvalidCastException
Message = Не удалось привести тип объекта "MySQL.Forms.MenuItemImpl" к типу "MySQL.GUI.Workbench.Plugins.DockablePlugin".
FullText = System.InvalidCastException: Не удалось привести тип объекта "MySQL.Forms.MenuItemImpl" к типу "MySQL.GUI.Workbench.Plugins.DockablePlugin".
   в MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   в MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   в MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   в boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   в wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   в MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   в MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   в System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   в MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   в System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   в System.Windows.Forms.Control.WndProc(Message& m)
   в System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   в System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   в System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   в System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Just use the program 15 minutes...)
[9 Aug 2012 11:16] Valeriy Kravchuk
This is a duplicate of bug #66013.