Bug #66272 Table not editable
Submitted: 9 Aug 2012 9:57 Modified: 9 Aug 2012 10:01
Reporter: Benjamin Wilger Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Aug 2012 9:57] Benjamin Wilger
Description:
Some tables are not editable on double click or via the context menu.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\bwilger\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: 2x Intel(R) Xeon(R) CPU           W3503  @ 2.40GHz, 12.0 GiB RAM
Active video adapter (0): VNC Mirror Driver
Installed video RAM: 0 MB
Current video mode: 1920 x 1200 x 4294967296 Farben
Used bit depth: 32
Driver version: 1.8.0.0
Installed display drivers: NULL
Active video adapter (1): ATI FirePro 2260
Installed video RAM: 256 MB
Current video mode: 1920 x 1200 x 4294967296 Farben
Used bit depth: 32
Driver version: 8.593.100.8000
Installed display drivers: atiumd64.dll,atidxx64.dll,atiumdag,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Current user language: Deutsch (Deutschland)

Exception = System.InvalidCastException
Message = Das Objekt des Typs "MySQL.Forms.MenuItemImpl" kann nicht in Typ "MySQL.GUI.Workbench.Plugins.DockablePlugin" umgewandelt werden.
FullText = System.InvalidCastException: Das Objekt des Typs "MySQL.Forms.MenuItemImpl" kann nicht in Typ "MySQL.GUI.Workbench.Plugins.DockablePlugin" umgewandelt werden.
   bei MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   bei MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   bei MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   bei boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   bei wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   bei MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   bei MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   bei System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   bei MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Create a simple model with some tables. Double click on any table to edit it. The table editing window should appear, but ocassionally does not.
[9 Aug 2012 10:01] Valeriy Kravchuk
This is a duplicate of bug #66013.