Bug #66270 dbl clicked a tbl in diagram
Submitted: 9 Aug 2012 7:50 Modified: 9 Aug 2012 9:29
Reporter: Henning Bopp Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[9 Aug 2012 7:50] Henning Bopp
Description:
I created some Tables in Model-View (just tbl-names, no fields). Then changed to diagram and dragged the tables there. After a dbl-click to the table workbench crashed.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\bopp\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
CPU: 4x Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz, 15.9 GiB RAM
Active video adapter (0): Intel(R) HD Graphics
Installed video RAM: -1988 MB
Current video mode: 1920 x 1200 x 4294967296 Farben
Used bit depth: 32
Driver version: 8.15.10.2696
Installed display drivers: igdumd64.dll,igd10umd64.dll,igd10umd64.dll,igdumd32,igd10umd32,igd10umd32
Current user language: Deutsch (Deutschland)

Exception = System.InvalidCastException
Message = Das Objekt des Typs "MySQL.Forms.MenuItemImpl" kann nicht in Typ "MySQL.GUI.Workbench.Plugins.DockablePlugin" umgewandelt werden.
FullText = System.InvalidCastException: Das Objekt des Typs "MySQL.Forms.MenuItemImpl" kann nicht in Typ "MySQL.GUI.Workbench.Plugins.DockablePlugin" umgewandelt werden.
   bei MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   bei MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   bei MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   bei boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   bei wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   bei MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   bei MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   bei System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   bei MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   bei System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   bei System.Windows.Forms.Control.WndProc(Message& m)
   bei System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
see above ;-) I didn't check if it is repro.
[9 Aug 2012 7:53] Henning Bopp
The Error does not appear on every table I created. I created tables named:
- dokument
- gruppe
- parameter
- probe
- split
- termin

It doesn't crash if I click on "gruppe". But does on any other table. It also crashes if in "Mysql Model" view.
[9 Aug 2012 9:29] Valeriy Kravchuk
This is a duplicate of bug #66013.