Bug #66264 sxasas
Submitted: 8 Aug 2012 17:42 Modified: 8 Aug 2012 20:37
Reporter: LUIGI GUERREROS Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[8 Aug 2012 17:42] LUIGI GUERREROS
Description:
ajjja

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\}\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
CPU: 4x Intel(R) Core(TM) i3-2350M CPU @ 2.30GHz, 3.0 GiB RAM
Active video adapter (0): Intel(R) HD Graphics Family
Installed video RAM: 1285 MB
Current video mode: 1366 x 768 x 4294967296 colores
Used bit depth: 32
Driver version: 8.15.10.2353
Installed display drivers: igdumd64.dll,igd10umd64.dll,igd10umd64.dll,igdumdx32,igd10umd32,igd10umd32
Current user language: Español (Perú)

Exception = System.InvalidCastException
Message = No se puede convertir un objeto de tipo 'MySQL.Forms.ToolBarItemImpl' al tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: No se puede convertir un objeto de tipo 'MySQL.Forms.ToolBarItemImpl' al tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   en MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   en MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   en MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   en boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   en wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   en MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   en MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   en System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   en MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   en System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   en System.Windows.Forms.Control.WndProc(Message& m)
   en System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   en System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   en System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   en System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
aakakakak
[8 Aug 2012 20:37] Valeriy Kravchuk
This is a duplicate of bug #66013.