Bug #66247 Re-opem table for edit
Submitted: 7 Aug 2012 16:45 Modified: 7 Aug 2012 17:08
Reporter: leonardo Xavier Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[7 Aug 2012 16:45] leonardo Xavier
Description:
Editing table, don´´t open the teble to edit, with double clics, don´´t response, ....BD in remote server.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9724
Configuration Directory: C:\Users\Leonardo Xavier\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.41
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: 2x Pentium(R) Dual-Core CPU       T4300  @ 2.10GHz, 2.9 GiB RAM
Active video adapter (0): NVIDIA GeForce 8200M G 
Installed video RAM: 128 MB
Current video mode: 1366 x 768 x 4294967296 colors
Used bit depth: 32
Driver version: 8.17.11.9745
Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Current user language: Português (Brasil)

Exception = System.InvalidCastException
Message = Não é possível converter um objeto do tipo 'MySQL.Forms.ToolBarItemImpl' no tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Não é possível converter um objeto do tipo 'MySQL.Forms.ToolBarItemImpl' no tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   em MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   em MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   em MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   em boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   em wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   em MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   em MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   em System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   em MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   em System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   em System.Windows.Forms.Control.WndProc(Message& m)
   em System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   em System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
after insert new table, wen i re-opem table to edit, hapen this message.
[7 Aug 2012 17:08] Valeriy Kravchuk
This is a duplicate of bug #66013.