Bug #66202 Working on diagram
Submitted: 4 Aug 2012 22:17 Modified: 5 Aug 2012 8:43
Reporter: Jeferson Giovani Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft (build 8400), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[4 Aug 2012 22:17] Jeferson Giovani
Description:
Workbench closes unexpectedly sametimes and not open tables for editing. I've close and open the application for work.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\GIOVANI\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft  (build 8400), 64-bit
CPU: 8x Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz, 6.0 GiB RAM
Active video adapter (0): Intel(R) HD Graphics Family (Microsoft Corporation - WDDM 1.2)
Installed video RAM: -1988 MB
Current video mode: 1920 x 1080 x 4294967296 cores
Used bit depth: 32
Driver version: 9.17.10.2736
Installed display drivers: igdumd64.dll,igd10umd64.dll,igd10umd64.dll,igdumd32,igd10umd32,igd10umd32
Current user language: Português (Brasil)

Exception = System.InvalidCastException
Message = Não é possível converter um objeto do tipo 'MySQL.Forms.MenuItemImpl' no tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Não é possível converter um objeto do tipo 'MySQL.Forms.MenuItemImpl' no tipo 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   em MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   em MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   em MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   em boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   em wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   em MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   em MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   em System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   em MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   em System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   em System.Windows.Forms.Control.WndProc(Message& m)
   em System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   em System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
Ever.
[5 Aug 2012 8:43] Valeriy Kravchuk
This is a duplicate of bug #66013.