Bug #66183 Table Edit error
Submitted: 3 Aug 2012 11:54 Modified: 3 Aug 2012 13:00
Reporter: Łukasz Schab Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[3 Aug 2012 11:54] Łukasz Schab
Description:
After first table edit cannot edit second table

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\lschab\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
CPU: 2x Pentium(R) Dual-Core  CPU      E6700  @ 3.20GHz, 3.0 GiB RAM
Active video adapter (0): NVIDIA GeForce 210 
Installed video RAM: 512 MB
Current video mode: 1920 x 1080 x 4294967296 colors
Used bit depth: 32
Driver version: 8.17.12.9610
Installed display drivers: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Current user language: Polski (Polska)

Exception = System.InvalidCastException
Message = Nie można rzutować obiektu typu 'MySQL.Forms.ToolBarItemImpl' na typ 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Nie można rzutować obiektu typu 'MySQL.Forms.ToolBarItemImpl' na typ 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   w MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   w MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   w MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   w boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   w wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   w MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   w MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   w System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   w MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   w System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   w System.Windows.Forms.Control.WndProc(Message& m)
   w System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   w System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   w System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   w System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
After first table edit cannot edit second table
[3 Aug 2012 13:00] Valeriy Kravchuk
This is a duplicate of bug #66013.