Bug #66122 can't click on table on the err diagram
Submitted: 31 Jul 2012 15:41 Modified: 14 Aug 2012 18:59
Reporter: [ name withheld ] Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 Service Pack 1 (build 7601), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter
Triage: Needs Triage: D2 (Serious)

[31 Jul 2012 15:41] [ name withheld ]
Description:
when create a new table can't click on the first table created  

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9727
Configuration Directory: C:\Users\djibril.bah\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench 5.2 CE
Cairo Version: 1.8.8
OS: Microsoft Windows 7  Service Pack 1 (build 7601), 64-bit
CPU: Intel(R) Celeron(R) CPU          900  @ 2.20GHz, 3.0 GiB RAM
Active video adapter (0): Mobile Intel(R) 4 Series Express Chipset Family
Installed video RAM: 1292 MB
Current video mode: 1440 x 900 x 4294967296 couleurs
Used bit depth: 32
Driver version: 8.15.10.2302
Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Active video adapter (1): Mobile Intel(R) 4 Series Express Chipset Family
Installed video RAM: 0 MB
Current video mode: 1920 x 1080 x 4294967296 couleurs
Used bit depth: 32
Driver version: 8.15.10.2302
Installed display drivers: igdumd64.dll,igd10umd64.dll,igdumdx32,igd10umd32
Current user language: Français (Canada)

Exception = System.InvalidCastException
Message = Impossible d'effectuer un cast d'un objet de type 'MySQL.Forms.MenuItemImpl' en type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Impossible d'effectuer un cast d'un objet de type 'MySQL.Forms.MenuItemImpl' en type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   à MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   à MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   à MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   à boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   à wb.ModelDiagramForm.handle_mouse_double_click(ModelDiagramForm* , MouseButton , Int32 , Int32 , EventState )
   à MySQL.Workbench.ModelDiagramFormWrapper.OnMouseDoubleClick(MouseEventArgs e, Int32 X, Int32 Y, Keys keystate, MouseButtons buttons)
   à MySQL.GUI.Workbench.ModelDiagramForm.CanvasPanel_MouseDoubleClick(Object sender, MouseEventArgs e)
   à System.Windows.Forms.Control.OnMouseDoubleClick(MouseEventArgs e)
   à MySQL.Utilities.WindowsCanvasViewerPanel.OnMouseDoubleClick(MouseEventArgs e)
   à System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   à System.Windows.Forms.Control.WndProc(Message& m)
   à System.Windows.Forms.ScrollableControl.WndProc(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   à System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

How to repeat:
create a table on the EER diagram, and create new one. click back to the first one. impossible
[31 Jul 2012 15:57] Miguel Solorzano
Thank you for the bug report.
[14 Aug 2012 18:59] Alfredo Kojima
Duplicate of bug #66013