Bug #66080 After a fresh install the Diagram tool is having trouble editing tables
Submitted: 30 Jul 2012 8:17 Modified: 30 Jul 2012 8:53
Reporter: Raymond Powers Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:5.2.41 OS:Microsoft Windows (Microsoft Windows 7 (build 7600), 64-bit)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[30 Jul 2012 8:17] Raymond Powers
Description:
Bug while editing tables. I have created a few identifying relationships. I decided to delete those relationships. I clicked Keep though for the column names. I made a mistake, so I wanted to edit the tables to delete those new columns. After deleting the columns of one table MySQL gives me an error everytime I try to edit another table.

----- Developer Notes -----

MySQL Workbench CE for Windows version 5.2.41  revision 9724
Configuration Directory: C:\Users\Administrator\AppData\Roaming\MySQL\Workbench
Data Directory: C:\Program Files (x86)\MySQL\MySQL Workbench CE 5.2.41
Cairo Version: 1.8.8
OS: Microsoft Windows 7  (build 7600), 64-bit
CPU: 4x Intel(R) Core(TM) i5 CPU       M 430  @ 2.27GHz, 3.9 GiB RAM
Active video adapter (0): ATI Mobility Radeon HD 5470  
Installed video RAM: 512 MB
Current video mode: 1366 x 768 x 4294967296 colors
Used bit depth: 32
Driver version: 8.692.1.0
Installed display drivers: atiu9p64 aticfx64 aticfx64 atiu9pag aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Current user language: Japanese (Japan)

Exception = System.InvalidCastException
Message = Unable to cast object of type 'MySQL.Forms.MenuItemImpl' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
FullText = System.InvalidCastException: Unable to cast object of type 'MySQL.Forms.MenuItemImpl' to type 'MySQL.GUI.Workbench.Plugins.DockablePlugin'.
   at MySQL.GUI.Workbench.Plugins.DockablePlugin.GetFromFixedPtr(IntPtr ptr)
   at MySQL.GUI.Workbench.MainForm.ShowPlugin(IntPtr ptr)
   at MySQL.Forms.AppImpl.show_editor_wrapper(UInt32 native_handle)
   at boost.detail.function.void_function_invoker1<void (__cdecl*)(unsigned int),void,unsigned int>.invoke(function_buffer* function_ptr, UInt32 a0)
   at wb.WBContext.flush_idle_tasks(WBContext* )
   at MySQL.Workbench.WbContext.flush_idle_tasks()
   at MySQL.GUI.Workbench.Program.timer_Tick(Object sender, EventArgs e)

How to repeat:
I try to click edit table after having deleted a few columns of another table.
[30 Jul 2012 8:53] Valeriy Kravchuk
This is a duplicate of bug #66013.