Bug #64308 Check for updates failed, proxy authentication required
Submitted: 13 Feb 2012 9:54 Modified: 4 Mar 23:01
Reporter: Matthias Maier Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.6 OS:Microsoft Windows (7 SP1)
Assigned to: CPU Architecture:Any
Tags: authentication, Error 407, proxy
Triage: Needs Triage: D3 (Medium)

[13 Feb 2012 9:54] Matthias Maier
Description:
Check for new updates is not possible behind a proxy server with authentication.

H T T P Error 407: Proxy Authentication Required

How to repeat:
Help -> Check for Updates 

Suggested fix:
Use system default proxy configuration or make it possible to configure proxy settings.
[13 Feb 2012 12:51] Miguel Solorzano
Are you tried to enable the proxy server in LAN settings in Internet Explorer?. Thanks.
[13 Feb 2012 12:57] Matthias Maier
Yes, Proxy Server is enabled in Internet Explorer LAN Setting. Due to corporate LAN, a config script is used distributing correct proxy settings. Other programs can access internet through proxy without additional configuration.
[28 Feb 2012 9:31] roel paesen
bug confirmed on windows XP SP3, version 5.2.38

- proxy information is filled in in IE-settings
- indeed generates a http error 407 (proxy authentication required)

suggested fixes should work
[17 Mar 2012 14:39] Valeriy Kravchuk
Bug #64560 was marked as a duplicate of this one.
[21 May 2012 9:57] Matthias Maier
What about fixes suggested by Roel Paesen?
Workbench version 5.2.40 does still have HTTP Error 407.
[12 Sep 2012 7:23] Matthias Maier
This is not a duplicate of Bug #64560 because all websites in Help -> MySQL.com Website, Workbench product page, Report a bug, ... are displayed correctly. But Help -> Check for updates still leads to message: Check for updates failed. HTTP Error 407: Proxy Authentication Required
[6 Mar 2013 7:00] Justinas Urbanavičius
Still not fixed on version 5.2.45, 

Environment: Windows 7 Enterprise x64
[1 Jul 2013 8:19] Matthias Maier
Also in 6.0 beta the update checking is not working. Following error message appears:

Check for updates failed
<urlopen error [Errno 10060] .... >

Menu: Help -> View reported bugs
works, so connection to the internet is possible
[10 Oct 2014 12:06] Daniël van Eeden
Also happens in 6.1.7.
[24 Mar 2015 14:55] Edgar Knapp
Reproduced on Windows 8.1 pro, 64-bit. Proxy settings work for access to the MySQL Bugs page inside Workbench 6.2.4, but not to check for updates.
[23 Apr 2015 15:10] Matthias Maier
Still happens in 6.3.3
[21 Dec 2015 10:35] Matthias Maier
Also after fixing bug #75132 in v6.3.6 it is still not working.
[19 Jul 2016 13:39] Ygor Oliveira
Bug is still here, in 6.3 CE
[25 Feb 23:14] Miguel Tadeu
Posted by developer:
 
commit id: 697933723788d9058841f1b74342153fc9b85d59
[4 Mar 23:01] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.16 release, and here's the changelog entry:

The operation to check for MySQL Workbench updates (from Help) returned an
error when used behind a proxy server with authentication.

Thank you for the bug report.