Bug #63264 UpdateBatch fail if query use table alias
Submitted: 15 Nov 2011 13:57 Modified: 21 Dec 2012 9:20
Reporter: Nicolas Lips Email Updates:
Status: Won't fix Impact on me:
None 
Category:Connector / ODBC Severity:S3 (Non-critical)
Version:3.51 OS:Microsoft Windows
Assigned to: Bogdan Degtyariov CPU Architecture:Any
Tags: alias, UpdateBatch

[15 Nov 2011 13:57] Nicolas Lips
Description:
Call UpdateBatch(adAffectCurrent) on a recordset built using table alias throw exception 0x80040E37 telling table doesn't exist.

Sample query :
SELECT
T1.fieldA AS F1
FROM
table AS T1

Erreor message : Table 'T1' doesn't exist

How to repeat:
Sample query :
SELECT
T1.fieldA AS F1
FROM
table AS T1

Erreor message : Table 'T1' doesn't exist
[15 Nov 2011 14:21] Valeriy Kravchuk
What exact version, 3.51.xx do you use? 3.51.29 is the latest in this branch, but I'd suggest to upgrade to 5.1.9 anyway.
[15 Nov 2011 16:44] Nicolas Lips
Exact version is 3.51.27
[15 Nov 2011 17:34] Valeriy Kravchuk
So, please, check if 3.51.29 is affected by the same problem.
[17 Nov 2011 16:55] Nicolas Lips
The problem persists in version 3.51.29
[18 Nov 2011 9:35] Bogdan Degtyariov
Version 5.1 works well with this.
3.51.29 failed.

Here is the fragment from the general query log:

111118 20:25:16    72 Query     SELECT @@tx_isolation
                   72 Query     DROP TABLE IF EXISTS bug63264
                   72 Query     CREATE TABLE bug63264 (id int)
                   72 Query     SELECT T1.id as F1 FROM bug63264 AS T1
                   72 Query     INSERT INTO `test`.`bug63264`(`F1`) VALUES (10)

It is clearly visible that INSERT is referring a non-existing column `F1`.
My VB test case did not show any table-related errors.
[18 Nov 2011 9:35] Bogdan Degtyariov
test case

Attachment: bug63264.vbs (application/octet-stream, text), 1.18 KiB.

[21 Dec 2012 9:18] Hemant Dangi
This bug seems to be duplicate of BUG#6157.
[21 Dec 2012 9:20] Hemant Dangi
Issue not found in 5.2.