Bug #62342 Can't process a big mysqldump script
Submitted: 4 Sep 2011 0:03 Modified: 9 Sep 2011 17:51
Reporter: Анатолий Кирсанов Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.34 OS:Microsoft Windows (Vista SP2 Home Basic Russian)
Assigned to: CPU Architecture:Any

[4 Sep 2011 0:03] Анатолий Кирсанов
Description:
.Net connector 6.4.3

I exported one big table using mysqldump. Resulting sql script was 71 Mb long. Workbench used 1.2 Gm of system memory and shown an exception System.OutOfMemoryException. 

How to repeat:
1. Export big table into a sql script using mysqldump.
2. Open MySQL Workbench and SQL Editor (Edit SQL Script)
3. Locate a script with auto execution.
[4 Sep 2011 0:04] Анатолий Кирсанов
Exception screeshot

Attachment: workbench-error.jpg (image/jpeg, text), 41.32 KiB.

[5 Sep 2011 12:01] Miguel Solorzano
Could you please provide the output of Help->System Info. Thanks.
[5 Sep 2011 13:23] Анатолий Кирсанов
MySQL Workbench CE for Windows version 5.2.34

Configuration Directory: C:\Users\akir\AppData\Roaming\MySQL\Workbench

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is not available on this system, so GDI is used for rendering.

OS: Microsoft Windows Vista Home Basic Edition Service Pack 2 (build 6002), 32-bit

CPU: 2x Genuine Intel(R) CPU            2140  @ 1.60GHz, 2.0 GiB RAM

Active video adapter: Intel(R) G33/G31 Express Chipset Family

Installed video RAM: 320 MB

Current video mode: 1024 x 768 x 65536 colors

Used bit depth: 16

Driver version: NULL

Installed display drivers: igdumdx32.dll

Current user language: Русский (Россия)
[9 Sep 2011 17:51] Alfredo Kojima
Duplicate of bug #55312
A new feature to process (but not edit) huge files will be added.