Bug #60293 SHOW ENGINE INNODB STATUS: full path names instead of filenames
Submitted: 1 Mar 2011 12:35 Modified: 24 Dec 2012 9:40
Reporter: Daniël van Eeden Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:5.5.11 OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Triage: Needs Triage: D3 (Medium)

[1 Mar 2011 12:35] Daniël van Eeden
Description:
In 5.5.8 the SHOW ENGINE INNODB output shows full paths in the SEMAPHORES section. It
makes the output less readable. Is this probably related to the switch from autotools to
cmake.

----------
SEMAPHORES
----------
OS WAIT ARRAY INFO: reservation count 2720, signal count 2710
--Thread 2836126576 has waited at
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/log/log0log.c
line 2026 for 1.00 seconds the semaphore:
S-lock on RW-latch at 0x9a082b8 created in file
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/log/log0log.c
line 832
a writer (thread id 2836126576) has reserved it in mode  exclusive
number of readers 0, waiters flag 1, lock_word: 0
Last time read locked in file
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/log/log0log.c
line 2049
Last time write locked in file
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/log/log0log.c
line 1846
--Thread 2813647728 has waited at
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/include/log0log.ic
line 405 for 1.00 seconds the semaphore:
Mutex at 0x9a08194 created file
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/log/log0log.c
line 771, lock var 1
waiters flag 1
Mutex spin waits 205506, rounds 342214, OS waits 1764
RW-shared spins 723, rounds 18436, OS waits 611
RW-excl spins 254, rounds 5388, OS waits 169
Spin rounds per wait: 1.67 mutex, 25.50 RW-shared, 21.21 RW-excl

Original bug report: Bug #59273

How to repeat:
SHOW ENGINE INNODB STATUS\G

Suggested fix:
use basename
[1 Mar 2011 13:59] Valeriy Kravchuk
Bug #59273 is fixed only in 5.5.10 (to be released soon). So, surely this is repeatable with 5.5.8 and 5.5.9. I think it is just a duplicate of bug #59273 (as well as Bug #60292)...
[1 Mar 2011 18:50] Daniël van Eeden
As shown below it's not a duplicate.

mysql [localhost] {msandbox} ((none)) > set profiling=1;
Query OK, 0 rows affected (0.00 sec)

mysql [localhost] {msandbox} ((none)) > select now();
+---------------------+
| now()               |
+---------------------+
| 2011-03-01 18:42:48 |
+---------------------+
1 row in set (0.00 sec)

mysql [localhost] {msandbox} ((none)) > show profile source for query 1;
+--------------------+----------+-----------------------+--------------+-------------+
| Status             | Duration | Source_function       | Source_file  | Source_line |
+--------------------+----------+-----------------------+--------------+-------------+
| starting           | 0.000093 | NULL                  | NULL         |        NULL |
| Opening tables     | 0.000016 | open_tables           | sql_base.cc  |        4737 |
| query end          | 0.000006 | mysql_execute_command | sql_parse.cc |        4316 |
| closing tables     | 0.000003 | mysql_execute_command | sql_parse.cc |        4368 |
| freeing items      | 0.000018 | mysql_parse           | sql_parse.cc |        5508 |
| logging slow query | 0.000002 | log_slow_statement    | sql_parse.cc |        1450 |
| cleaning up        | 0.000004 | dispatch_command      | sql_parse.cc |        1406 |
+--------------------+----------+-----------------------+--------------+-------------+
7 rows in set (0.00 sec)

mysql [localhost] {msandbox} ((none)) > show engine innodb mutex;
+--------+----------------------------------------------------------------+------------+
| Type   | Name                                                           | Status     |
+--------+----------------------------------------------------------------+------------+
| InnoDB | /home/dveeden/dev/mysql-5.5/storage/innobase/log/log0log.c:771 | os_waits=3 |
| InnoDB | /home/dveeden/dev/mysql-5.5/storage/innobase/log/log0log.c:832 | os_waits=7 |
+--------+----------------------------------------------------------------+------------+
2 rows in set (0.00 sec)

mysql [localhost] {msandbox} ((none)) > select version();
+-----------+
| version() |
+-----------+
| 5.5.11    |
+-----------+
1 row in set (0.00 sec)

This is mysql-5.5 rev 3357
[1 Mar 2011 19:06] Sveta Smirnova
Thank you for the feedback.

Verified as described with version 5.6.2
[24 Dec 2012 9:40] Erlend Dahl
Fixed under the heading of bug#58999. Closing as duplicate.