Bug #60292 SHOW ENGINE INNODB MUTEX: full path names instead of filenames
Submitted: 1 Mar 2011 12:32 Modified: 24 Dec 2012 9:40
Reporter: Daniël van Eeden Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:5.5.9 OS:Any
Assigned to: Assigned Account CPU Architecture:Any
Tags: regression
Triage: Needs Triage: D4 (Minor)

[1 Mar 2011 12:32] Daniël van Eeden
Description:
mysql> SHOW ENGINE INNODB MUTEX;
+--------+------------------------------------------------------------------------------------------------------------------+---------------+
| Type   | Name                                                                          
                                  | Status        |
+--------+------------------------------------------------------------------------------------------------------------------+---------------+
| InnoDB |
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/log/log0log.c:771
         | os_waits=1418 |
| InnoDB |
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/buf/buf0buf.c:1243
        | os_waits=7    |
| InnoDB |
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/buf/buf0buf.c:1208
        | os_waits=789  |
| InnoDB |
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/fil/fil0fil.c:1559
        | os_waits=50   |
| InnoDB |
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/srv/srv0srv.c:996
         | os_waits=194  |
| InnoDB | combined
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/buf/buf0buf.c:898
| os_waits=2    |
| InnoDB |
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/log/log0log.c:832
         | os_waits=162  |
| InnoDB | combined
/export/home/pb2/build/sb_0-2629600-1291401802.22/mysqlcom-pro-5.5.8/storage/innobase/buf/buf0buf.c:898
| os_waits=1667 |
+--------+------------------------------------------------------------------------------------------------------------------+---------------+
8 rows in set (0.00 sec)

With 5.1 this didn't give full path names. 
This is because of the cmake marcro's.
Original bug report: Bug #59273

How to repeat:
 SHOW ENGINE INNODB MUTEX;

Suggested fix:
use basename
[1 Mar 2011 13:55] Valeriy Kravchuk
Thank you for the bug report. Verified with 5.5.8 and 5.5.9.
[1 Mar 2011 14:07] Daniël van Eeden
Just basename won't work as the topmost directory is shown in the output of 5.1 (srv/srv0srv.c:888 for example)
[29 Apr 2011 12:57] Daniël van Eeden
This seems to be fixed between 5.5.11 and mysql-5.5 by using innobase_basename. This will probably also fix Bug #60293.

$ bzr log -c 2995.37.163 storage/innobase/handler/ha_innodb.cc
------------------------------------------------------------
revno: 2995.37.163
committer: Jimmy Yang <jimmy.yang@oracle.com>
branch nick: mysql-trunk-innodb
timestamp: Fri 2011-02-25 00:33:13 -0800
message:
  Fix Bug #11765975 __FILE__ macros expanded to full path instead of relative
  in CMake builds
  
  rb://600 approved by Sunny Bains
[24 Dec 2012 9:40] Erlend Dahl
Fixed under the heading of bug#58999. Closing as duplicate.