Bug #60046 Cannot Alter Some Routines
Submitted: 9 Feb 2011 10:55 Modified: 27 Apr 2011 16:57
Reporter: arnaud lemercier Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.31 CE OS:Microsoft Windows (XP)
Assigned to: CPU Architecture:Any
Triage: Needs Triage: D2 (Serious)

[9 Feb 2011 10:55] arnaud lemercier
Description:
Hello,

When I do a "right click" on a routine and I click on "Alter Routine.."
The editing window opens for some routines but for others, nothing happens except a message in the status bar saying "Finished parsing Mysql SQL script".

How to repeat:
You can try with the Routine (in Private Comment)
[9 Feb 2011 11:16] Miguel Solorzano
Thank you for the bug report. Could you please provide the model file (private if you wish)?. Thanks in advance.
[9 Feb 2011 12:54] arnaud lemercier
Hello, my mwb file is more than 500Ko.
How can transfert it ?
[9 Feb 2011 15:29] Miguel Solorzano
You can upload it within a zip file named bug60046.zip at:

ftp://ftp.mysql.com/pub/mysql/upload/

Thanks in advance.

Also you can try if the zip file can be attached here.
[9 Feb 2011 15:41] arnaud lemercier
The file is on the FTP server
[9 Feb 2011 16:02] Miguel Solorzano
Thank you for the feedback.
[18 Feb 2011 19:56] Alfredo Kojima
What server version was used? The model provided doesn't contain any routines and the pasted routine doesn't execute in MySQL 5.5.8, because of some syntax errors. Once the errors are fixed, I was able to use ALTER on the routine.
[22 Feb 2011 11:09] arnaud lemercier
Hello,

The model contains 5 routines :
 - getConflictPeriode
 - getDisponibiliteByPeriode
 - getDisponibiliteTeacher
 - getStatsNbLearner
 - getTeacherFavoriteList

The version of server is 5.0.45-Debian_1ubuntu3.4
[5 Mar 2011 15:58] Ivan Cachicatari
I have the same problem in linux with mysql-5.1.49-1ubuntu8, 

I reported it as new bug (sorry)

http://bugs.mysql.com/bug.php?id=60354
[14 Apr 2011 23:31] Alfredo Kojima
The problem is that the SPs have some syntax that is deprecated by the version of SQL WB knows. 
For example, TYPE=MyISAM in the CREATE TEMPORARY TABLE in the SP you pasted, is flagged as error in MySQL 5.1+, so WB can't reverse engineer that. 

At the moment, Workbench supports MySQL server syntax for version 5.1 and there are no plans to support 5.0 syntax.

You can workaround by removing the TYPE=MyISAM part from the SQL and fixing the compat errors you have in the other stored procedures. You can view the parts WB interprets as errors in the SQL Editor, errors will be marked with a red X next to the line number.
[27 Apr 2011 16:57] Valeriy Kravchuk
Looks like not a bug based on last comment (and assuming this is about 5.0 specific syntax used that is not supported in MySQL 5.1+ any more).