Bug #59854 Protected Memory
Submitted: 31 Jan 2011 21:12 Modified: 2 Feb 2011 4:16
Reporter: Andre Santos Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: Administration Severity:S2 (Serious)
Version:5.2.31-CE OS:Microsoft Windows (Windows 7)
Assigned to: CPU Architecture:Any

[31 Jan 2011 21:12] Andre Santos
Description:
When trying to create a New Server Instance, at the 3º window of the Wizard (the Test to DB Connection), the connect is great, but when I click NEXT, the error-window pops-up:

[TENTATIVA DE LEITURA OU GRAVAÇÃO EM MEMÓRIA PROTEGIDA. NORMALMENTE, ISSO É UMA INDICAÇÃO DE QUE OUTRA MEMÓRIA ESTÁ DANIFICADA

(My poor translate: Reading or writing in protected memory try. Generally, this is a indication that the other memory is damaged.)

We are sorry for the inconvenience but an unexpected exception has been raised by one of the MySQL Workbench modules. In order to fix this issue we would kindly ask you to file a bug report. You can do that by pressing the [Report Bug] button below. 

Please make sure to include a detailed description of your actions that lead to this problem.

Thanks a lot for taking the time to help us improve MySQL Workbench!

The MySQL Workbench Team]

COPY STACK TRACE TO CLIPBOARD:

[Exception = System.AccessViolationException
Message = Tentativa de leitura ou gravação em memória protegida. Normalmente, isso é uma indicação de que outra memória está danificada.
FullText = System.AccessViolationException: Tentativa de leitura ou gravação em memória protegida. Normalmente, isso é uma indicação de que outra memória está danificada.
   em std.basic_string<char,std::char_traits<char>,std::allocator<char> >.c_str(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* )
   em MySQL.?A0x4861a96a.CppStringToNative(basic_string<char\,std::char_traits<char>\,std::allocator<char> >* str)
   em MySQL.Forms.TextEntryImpl.set_text(TextEntry* self, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* text)
   em MySQL.MCallback2<void\,mforms::TextEntry \*\,std::basic_string<char\,std::char_traits<char>\,std::allocator<char> > const \&>.cpp_callback(TextEntry* a1, basic_string<char\,std::char_traits<char>\,std::allocator<char> >* a2)
   em sigc.internal.signal_emit0<void,sigc::nil>.emit(signal_impl* impl)
   em sigc.signal0<void,sigc::nil>.emit(signal0<void\,sigc::nil>* )
   em mforms.Wizard.next_clicked(Wizard* )
   em MySQL.Forms.WizardImpl.nextClick(Object sender, EventArgs arguments)
   em System.Windows.Forms.Control.OnClick(EventArgs e)
   em System.Windows.Forms.Button.OnClick(EventArgs e)
   em System.Windows.Forms.Button.WndProc(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   em System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   em System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)]

How to repeat:
It happened after a new install, just tried to make a connect to the DB with the Wizard "New Server Instance"
[31 Jan 2011 21:13] Andre Santos
UPDATE: I tried to open the program with the Admin. The problem is the same.
[31 Jan 2011 21:27] Miguel Solorzano
Thank you for the bug report. Could you please provide the output of Help->System Info. Are you trying to connect remote or local?. Thanks in advance.
[1 Feb 2011 18:04] Andre Santos
Help->System Info:

[MySQL Workbench CE for Windows version 5.2.31

Configuration Directory: C:\Users\Usuario\AppData\Roaming\MySQL\Workbench

Data Directory: C:\Program Files\MySQL\MySQL Workbench 5.2 CE

Cairo Version: 1.8.8

Rendering Mode: OpenGL is available on this system, so OpenGL is used for rendering.

OpenGL Driver Version: 2.1.2

OS: Microsoft Windows 7 Ultimate Edition (build 7600), 32-bit

CPU: 2x Intel(R) Pentium(R) D CPU 2.80GHz, 1.0 GiB RAM

Active video adapter: NVIDIA GeForce 7300 LE

Installed video RAM: 256 MB

Current video mode: 1280 x 720 x 4294967296 colors

Used bit depth: 32

Driver version: 8.17.12.5896

Installed display drivers: nvd3dum.dll

Current user language: Português (Brasil)
]

I'm using it in local, with XAMPP. I don't have a remote database, so I couldn't test it remote.

I'm glad to help a so good program like this, even if my english is soooo poor :D
[1 Feb 2011 19:29] Valeriy Kravchuk
Do you have a Windows service defined for your MySQL server from xampp?
[1 Feb 2011 21:44] Andre Santos
Valeriy Kravchuk, sorry, I'm new to this, I don't know how I discover it. I just used the typical installation of XAMPP, and I turn it on usin' the XAMPP Control Panel. Even the root password I didn't change (its empty, by default)...
[2 Feb 2011 4:16] Valeriy Kravchuk
Let's say this is a duplicate of bug #59578. Most people had noted this problem with default xampp installation.