Bug #59543 Replication test from eits suite rpl_row_until times out
Submitted: 17 Jan 2011 5:46 Modified: 11 Dec 2012 12:08
Reporter: Vinay Fisrekar Email Updates:
Status: Closed Impact on me:
None 
Category:Tests Severity:S3 (Non-critical)
Version:mysql-5.6, mysql-5.5, mysql-5.1 OS:Any
Assigned to: Assigned Account

[17 Jan 2011 5:46] Vinay Fisrekar
Description:
Replication test "rpl_row_until" times out in PB2 runs on mysql-5.6
This test also affected by change in "include/master-slave.inc"  file.
Review the test failure.

How to repeat:
perl mysql-test-run.pl --suite=engines/funcs --force --suite-timeout=500 --max-test-fail=0 --retry-failure=0 --mysqld=--default-storage-engine=innodb
--mysqld=--innodb rpl_row_until
[17 Jan 2011 12:06] Alfranio Correia
This test case also fails in 5.1.

http://tinyurl.com/6yjzb27
[19 Jan 2011 1:33] Anitha Gopi
Because these tests were maintained by System QA before and now by Server QA
[19 Jan 2011 1:33] Anitha Gopi
vinay,
Can you check if the problem is the same in 5.1
[19 Jan 2011 12:54] Vinay Fisrekar
Yes its failing on mysql-5.1 with result difference but we do not get timeout.
It is failing with following message. 
CURRENT_TEST: engines/funcs.rpl_row_until
mysqltest: At line 54: query 'select * from t2' failed: 1146: Table 'test.t2' doesn't exist.

In-fact , its failing on mysql-5.5 with time out.
[25 Jan 2011 15:21] Alfranio Correia
rpl_stm_until is also failing in 5.1:

http://pb2.norway.sun.com/?template=mysql_show_test_failure&search=yes&push_id=1936748&tes...
[26 Jan 2011 12:39] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/129651

3567 Alfranio Correia	2011-01-26
      Disabled rpl_row_until and rpl_stm_until due to BUG#59543.
[26 Jan 2011 12:40] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/129652

3568 Alfranio Correia	2011-01-26
      Disabled rpl_row_until and rpl_stm_until due to BUG#59543.
[26 Jan 2011 12:50] Bugs System
Pushed into mysql-trunk 5.6.2 (revid:alfranio.correia@oracle.com-20110126124817-snogk2k02t2oshzo) (version source revid:alfranio.correia@oracle.com-20110126124817-snogk2k02t2oshzo) (merge vers: 5.6.2) (pib:24)
[26 Jan 2011 12:51] Bugs System
Pushed into mysql-5.1 5.1.56 (revid:alfranio.correia@oracle.com-20110126123724-4rdm9bn9crpowy5g) (version source revid:alfranio.correia@oracle.com-20110126123724-4rdm9bn9crpowy5g) (merge vers: 5.1.56) (pib:24)
[26 Jan 2011 12:51] Bugs System
Pushed into mysql-5.5 5.5.10 (revid:alfranio.correia@oracle.com-20110126124409-ldahnb0h3ezgbhuz) (version source revid:alfranio.correia@oracle.com-20110126124409-ldahnb0h3ezgbhuz) (merge vers: 5.5.10) (pib:24)
[11 Dec 2012 12:08] Jon Stephens
Thank you for your bug report. This issue has been committed to our source repository of that product and will be incorporated into the next release.

If necessary, you can access the source repository and build the latest available version, including the bug fix. More information about accessing the source trees is available at

    http://dev.mysql.com/doc/en/installing-source.html