Bug #59301 Setup fails because of the assumption that the .net framework 4 resides on C:.
Submitted: 5 Jan 2011 9:17 Modified: 10 Jan 2011 16:27
Reporter: Michiel de Wolde Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S2 (Serious)
Version:6.3.6 OS:Microsoft Windows (XP 32 bit)
Assigned to: CPU Architecture:Any

[5 Jan 2011 9:17] Michiel de Wolde
Description:
The setup wizard fails with the error reported in earlier bug reports, "Setup Wizard ended prematurely because of an error", and performs a rollback. Investigation with a file access monitor shows that the wizard (or the OS on behalf of the wizard) attempts to locate the .net framework 4 in C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319, hence it assumes disk C:. On the particular system C: contains frameworks up to v3.5, belonging to an OS installation on another partition. The actual operational OS has the framework 4 located on disk E:.

Workaround: copy framework 4 from disk E: to disk C:. Thereafter the installation of the connector completes successfully. When comparing the frameworks on C: and E: it turs out that the wizard has correctly updated E: and not C:; it has updated the correct machine.config. Finally remove the copy from C:.

When installing with logging the offending part of the logfile is:
MSI (s) (8C:EC) [07:04:28:500]: Executing op: CustomActionSchedule(Action=ManagedDataInstall,ActionType=3073,Source=BinaryData,Target=CAQuietExec,CustomActionData="c:\windows\microsoft.net\framework\v4.0.30319\installUtil.exe" /LogToConsole=false /LogFile=  "E:\Program Files\MySQL\MySQL Connector Net 6.3.6\Assemblies\v2.0\MySql.Data.dll")
MSI (s) (8C:EC) [07:04:28:578]: Creating MSIHANDLE (73) of type 790536 for thread 3308
MSI (s) (8C:AC) [07:04:28:578]: Invoking remote custom action. DLL: E:\WINDOWS\Installer\MSIF2.tmp, Entrypoint: CAQuietExec
MSI (s) (8C!98) [07:04:28:703]: Creating MSIHANDLE (74) of type 790531 for thread 5016
CAQuietExec:  Error 0x80070003: Command failed to execute.

How to repeat:
Operational Windows XP OS on a disk other than C:. .net framework 4 correctly installed. Optionally Visual Studio 2010. Possibly .net frameworks older than 4 on disk C:. Run the connector / Net wizard mysql.data.msi v6.3.6.

Suggested fix:
Locate where disk C: is assumed. The log file of the installer, when performing a complete install, indicates an error around line 2020. Make sure the dynamically established location of the .net framework is used. The remaining of the log file indicates that the wizard has correctly detected, in this case, location E:.
[7 Jan 2011 7:09] Bogdan Degtyariov
The problem is repeatable in any version of Windows (32/64 bits) XP/Server/7
[7 Jan 2011 22:59] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/128208

959 Reggie Burnett	2011-01-07
      fixed installer problem with referencing C: directly and use of INSTALLUTIL property name (bug #59301)
[7 Jan 2011 23:00] Reggie Burnett
Fixed in 6.3.7
[10 Jan 2011 16:28] Tony Bedford
An entry has been added to the 6.3.7 changelog:

The setup wizard failed with the error “Setup Wizard ended prematurely because of an error”. This was because it assumed .NET Framework version 4.0 was located on the C: drive, when it was actually located on the E: drive.