Bug #58853 Code for fixing Bug #54863 is no longer needed
Submitted: 10 Dec 2010 0:42 Modified: 7 Jan 2011 11:14
Reporter: River D Email Updates:
Status: Closed Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.3.5 OS:Microsoft Windows
Assigned to: Reggie Burnett CPU Architecture:Any
Tags: MySqlDataAdapter
Triage: D2 (Serious)

[10 Dec 2010 0:42] River D
Description:
Lines 184-195 in class MySqlDataAdapter sourced in dataadapter.cs in assembly MySql.Data were introduced to fix Bug #54863. However we have found that on the newest .NET, at least version 3.5 and 4.0, these lines should be dropped out to prevent from causing new bugs, which imply that .NET has fixed its bug.

How to repeat:
refer Bug #54863

Suggested fix:
Drop out Lines 184-195 in class MySqlDataAdapter sourced in dataadapter.cs in assembly MySql.Data.
[10 Dec 2010 0:47] River D
Since it is causing codes to malfunction, I changed its severity to S1(Critical).
[10 Dec 2010 7:21] Valeriy Kravchuk
Duplicate of Bug #58374 (see last comment there).
[10 Dec 2010 7:22] Tonci Grgin
Hi River and thanks for your report.

It is actually a duplicate of Bug#58374 (you guys send mails from same domain, I guess you are colleagues?) but it's better documented so I'll work on this one.
[10 Dec 2010 8:20] Tonci Grgin
True, as of .NET FW 2.0, AcceptChanges() is called as a last step in IDataAdapter.Update method: http://msdn.microsoft.com/en-us/library/system.data.common.dataadapter.update%28v=VS.80%29...

So, we should fix this.
[14 Dec 2010 20:49] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/126845

854 Reggie Burnett	2010-12-14
      - removed extra call to Update in MySqlDataAdapter introduced with bug fix to bug #54863.
        It seems to not be necessary (bug #58853)
[14 Dec 2010 20:50] Reggie Burnett
Fixed in 6.0.8, 6.1.6, 6.2.5, 6.3.6+
[7 Jan 2011 11:14] Tony Bedford
An entry has been added to the 6.0.8, 6.1.6, 6.2.5, and 6.3.6 changelogs:

Code introduced to fix Bug#54863 proved problematic on .NET version 3.5 and above.