Bug #58831 large_tests.alter_table crashes the server
Submitted: 9 Dec 2010 3:30 Modified: 20 Dec 2010 3:11
Reporter: Anitha Gopi Email Updates:
Status: Closed Impact on me:
None 
Category:Tests: Server Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: Mattias Jonsson CPU Architecture:Any
Tags: pushbuild
Triage: Triaged: D3 (Medium)

[9 Dec 2010 3:30] Anitha Gopi
Description:
Seen in PB2, but with no stack trace

http://pb2.norway.sun.com/?action=archive_download&archive_id=2633817&pretty=please
Test case timeout after 3600 seconds

== /tmp/pb2/test/sb_0-2628482-1291503836.6/mysql-5.5.8-solaris10-sparc-64bit-test/mysql-test/var-big-tests/8/log/alter_table.log == 
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;
insert into t1 select * from t1;

 == /tmp/pb2/test/sb_0-2628482-1291503836.6/mysql-5.5.8-solaris10-sparc-64bit-test/mysql-test/var-big-tests/8/tmp/analyze-timeout-mysqld.1.err ==
mysqltest: Could not open connection 'default': 2013 Lost connection to MySQL server at 'waiting for initial communication packet', system error: 99

 - saving '/tmp/pb2/test/sb_0-2628482-1291503836.6/mysql-5.5.8-solaris10-sparc-64bit-test/mysql-test/var-big-tests/8/log/large_tests.alter_table/' to '/tmp/pb2/test/sb_0-2628482-1291503836.6/mysql-5.5.8-solaris10-sparc-64bit-test/mysql-test/var-big-tests/log/large_tests.alter_table/'
 - found 'core', moving it to '/tmp/pb2/test/sb_0-2628482-1291503836.6/mysql-5.5.8-solaris10-sparc-64bit-test/mysql-test/var-big-tests/log/large_tests.alter_table'
 - found 'core' (0/5)

Trying 'dbx' to get a backtrace
sh: dbx: not found

Problem could be reproduced on my laptop - Ubuntu 10.04 this time with a stack trace

#0  0xb76eb430 in __kernel_vsyscall ()
#0  0xb76eb430 in __kernel_vsyscall ()
#1  0xb76cb093 in pthread_kill () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x086c18b5 in my_write_core (sig=6) at /home/anitha/mysql/repo/mysql-5.5-bugteam/mysys/stacktrace.c:423
#3  0x08172a68 in handle_segfault (sig=6) at /home/anitha/mysql/repo/mysql-5.5-bugteam/sql/mysqld.cc:2512
#4  <signal handler called>
#5  0xb76eb430 in __kernel_vsyscall ()
#6  0xb75aab86 in poll () from /lib/tls/i686/cmov/libc.so.6
#7  0x0817713e in handle_connections_sockets () at /home/anitha/mysql/repo/mysql-5.5-bugteam/sql/mysqld.cc:5100
#8  0x081764b6 in mysqld_main (argc=50, argv=0xa446f38) at /home/anitha/mysql/repo/mysql-5.5-bugteam/sql/mysqld.cc:4570
#9  0x0816e92c in main (argc=8, argv=0xbf9923b4) at /home/anitha/mysql/repo/mysql-5.5-bugteam/sql/main.cc:24

How to repeat:
./mtr --big-test large_tests.alter_table
[9 Dec 2010 3:32] Anitha Gopi
PB2 complains of "[PB2] The child process exited without handshake." on all platforms. This means that PB2 did not detect an output from the test for the last 30 minutes. Root cause must be this crash

http://pb2.norway.sun.com/?template=show_pushes&branch=weekly-5.5-bugteam
[9 Dec 2010 13:11] Mattias Jonsson
If this test is relevant to run, the timeout should be increased. The test is checking for regression of bug#27029.

From the header of that file:
# The test for bug#27029 requires about 8 hours and 20 minutes on my
# fastest machine.  This test requires at least 60 GB of disk space.

Currently only run on a weekly basis through mysql-test/collections/default.weekly

Changed category, since it is not related to partitioning, only a test that will generate a very large table which take a lot of time and resources.
Generates a table of 4294967295 rows (4 G rows!!!).

So should we increase the limits in default.weekly, or simply remove this single test from the weekly run?

Are there always 60 GB disk available for the weekly runs?
[9 Dec 2010 14:05] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/126425

3514 Mattias Jonsson	2010-12-09
      Bug#58831: large_tests.alter_table crashes the server
      
      The tests generates 4 Billion rows which timeouts.
      
      Removed the test from the default weekly run.
[10 Dec 2010 6:11] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/126497

3418 Anitha Gopi	2010-12-10
      Bug# 58831. Remove large_tests.alter_table from the weekly run
[14 Dec 2010 13:00] Mattias Jonsson
pushed into mysql-5.1-bugteam, mysql-5.5-bugteam and mysql-trunk-bugfixing
[17 Dec 2010 12:48] Bugs System
Pushed into mysql-5.1 5.1.55 (revid:georgi.kodinov@oracle.com-20101217124435-9imm43geck5u55qw) (version source revid:mattias.jonsson@oracle.com-20101214120656-6kf94uo8jiymcq00) (merge vers: 5.1.55) (pib:24)
[17 Dec 2010 12:50] Bugs System
Pushed into mysql-5.5 5.5.9 (revid:georgi.kodinov@oracle.com-20101217124733-p1ivu6higouawv8l) (version source revid:mattias.jonsson@oracle.com-20101214121019-4a3xxe3eabc1n8ij) (merge vers: 5.5.8) (pib:24)
[17 Dec 2010 12:55] Bugs System
Pushed into mysql-trunk 5.6.1 (revid:georgi.kodinov@oracle.com-20101217125013-y8pb3az32rtbplc9) (version source revid:mats.kindahl@oracle.com-20101215103340-a0wp0yq8t4byel1o) (merge vers: 5.6.1) (pib:24)
[20 Dec 2010 3:11] Paul Dubois
Changes to test suite. No changelog entry needed.