Bug #57975 Can't write Polish diacritic sign 'ó' in 'Search for substring within...' field
Submitted: 4 Nov 2010 11:50 Modified: 6 Feb 2013 19:07
Reporter: Krzysztof Lorkowski Email Updates:
Status: Closed Impact on me:
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:5.2.29 CE OS:Windows (Vista Home Premium x64)
Assigned to: CPU Architecture:Any
Tags: polish diacritic sign 'ó', search for substring within data

[4 Nov 2010 11:50] Krzysztof Lorkowski
It is not possible to write Polish diacritic sign 'ó' in 'Search for sub-string within data' field. Normally I get the sign 'ó' by holding RIGHT ALT + O on the keyboard. All other Polish diacritic signs work fine. I tried to copy 'ó' from notepad and paste it to the 'Search for sub-string within data' field - it worked. My tables are coded in UTF-8 and there are Polish diacritic signs in almost all rows. It's very difficult to search for sub-strings if i can't use Polish 'ó'.

How to repeat:
It repeats every time.

Suggested fix:
I think the problem might be caused by some keyboard shortcut used in MySQL Workbench that uses RIGHT ALT + O.
[4 Nov 2010 12:47] MySQL Verification Team
Thank you for the bug report. Which kind of keyboard layout are you using?.
[4 Nov 2010 13:17] Krzysztof Lorkowski
My keyboard layout is: 'Polish programmer's'. Thank you for your interest and competence.
[29 Dec 2010 3:26] Alexey Kishkin
verified as described. I can easily enter (for instance) ł or ń in the search field, but alt+o (that must enter ó) just move focus to menu bar. The only way I was able to enter ó - is alt 00243.
[23 Apr 2011 18:37] Alfredo Kojima
bug #60924 is a duplicate
[22 Aug 2012 14:58] Alfredo Kojima
Can you try version 5.2.42? Does that still happen?
[29 Aug 2012 18:27] Krzysztof Lorkowski
I tried version 5.2.42 CE and everything works just fine. I checked all Polish diacritic signs to be sure.
Thank you for your interest and resolving my problem.
[6 Feb 2013 19:07] Alfredo Kojima
Closing bug as resolution confirmed by reporter