Bug #57482 server_uuid fails on PB2
Submitted: 15 Oct 2010 12:39 Modified: 20 Dec 2010 20:15
Reporter: Libing Song Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:trunk, next-mr OS:Any
Assigned to: CPU Architecture:Any
Tags: experimental, pb2, sporadic, test failure
Triage: Triaged: D1 (Critical)

[15 Oct 2010 12:39] Libing Song
Description:
main.server_uuid fails on PB2 because of some memory leaks.
Here is the url: http://tinyurl.com/29yvc5d

These memory leaks are not related to server_uuid directly. They appear in this test case, just because server_uuid restarts the server.

There are a couple of different errors.

http://tinyurl.com/2cprz9c   It is caused by Bug#46949.
http://tinyurl.com/29qkclf   It looks same as BUG#56649
http://tinyurl.com/26jmxj5
http://tinyurl.com/254etzy
http://tinyurl.com/26k56mc
http://tinyurl.com/2exdm6g

How to repeat:
Here is the url: http://tinyurl.com/29yvc5d
[2 Nov 2010 8:45] Alexander Nozdrin
The test case has been marked experimental starting from trunk.
[10 Nov 2010 9:46] Alexander Nozdrin
Attaching symptoms (just for the history):
--------------------------------------------------------------
main.server_uuid                         [ fail ]  Found warnings/errors in server log file!
        Test ended at 2010-10-09 04:21:37
line
==17654== 148,280 bytes in 2,222 blocks are still reachable in loss record 7 of 8
==17654==    at 0x4A05809: malloc (vg_replace_malloc.c:149)
==17654==    by 0xA9A570: my_malloc (my_malloc.c:38)
==17654==    by 0xAABE56: initialize_bucket (lf_hash.c:479)
==17654==    by 0xAABDA3: lf_hash_search (lf_hash.c:460)
==17654==    by 0x8B4E60: drop_table_share(PFS_thread*, bool, char const*, unsigned, char const*, unsigned) (pfs_instr_class.cc:921)
==17654==    by 0x8C3CDA: drop_table_share_v1 (pfs.cc:969)
==17654==    by 0x72CDED: ha_delete_table(THD*, handlerton*, char const*, char const*, char const*, bool) (handler.cc:2061)
==17654==    by 0x652EC7: mysql_rm_table_part2(THD*, TABLE_LIST*, bool, bool, bool, bool) (sql_table.cc:2402)
==17654==    by 0x653673: mysql_rm_table(THD*, TABLE_LIST*, char, char) (sql_table.cc:2045)
==17654==    by 0x5C4F05: mysql_execute_command(THD*) (sql_parse.cc:3090)
==17654==    by 0x5C9787: mysql_parse(THD*, char*, unsigned, Parser_state*) (sql_parse.cc:5591)
==17654==    by 0x5CADB8: dispatch_command(enum_server_command, THD*, char*, unsigned) (sql_parse.cc:1130)
==17654==    by 0x5CC221: do_command(THD*) (sql_parse.cc:802)
==17654==    by 0x6A0046: do_handle_one_connection(THD*) (sql_connect.cc:1201)
==17654==    by 0x6A0142: handle_one_connection (sql_connect.cc:1140)
==17654==    by 0x8C3BA1: pfs_spawn_thread (pfs.cc:1078)
^ Found warnings in /export/home2/pb2/test/sb_0-2376563-1286549776.99/mysql-5.6.99-m5-linux-x86_64-test/mysql-test/var-ps_row/log/mysqld.1.err
ok
--------------------------------------------------------------
main.server_uuid                         w1 [ fail ]  Found warnings/errors in server log file!
        Test ended at 2010-09-24 10:20:27
line
==7283== 68,424 bytes in 767 blocks are still reachable in loss record 8 of 9
==7283==    at 0x4A05809: malloc (vg_replace_malloc.c:149)
==7283==    by 0xA72EB4: my_malloc (my_malloc.c:38)
==7283==    by 0xA84792: initialize_bucket (lf_hash.c:479)
==7283==    by 0xA846DF: lf_hash_search (lf_hash.c:460)
==7283==    by 0xA22C74: find_or_create_file(PFS_thread*, PFS_file_class*, char const*, unsigned) (pfs_instr.cc:905)
==7283==    by 0xA3164B: get_thread_file_name_locker_v1 (pfs.cc:1408)
==7283==    by 0x660929: inline_mysql_file_open(unsigned, char const*, unsigned, char const*, int, int) (mysql_file.h:1039)
==7283==    by 0x6648BD: open_table_def(THD*, TABLE_SHARE*, unsigned) (table.cc:603)
==7283==    by 0x5731DC: get_table_share(THD*, TABLE_LIST*, char*, unsigned, unsigned, int*, unsigned) (sql_base.cc:544)
==7283==    by 0x61825D: fill_schema_table_from_frm(THD*, TABLE_LIST*, st_schema_table*, st_mysql_lex_string*, st_mysql_lex_string*, enum_schema_tables, bool) (sql_show.cc:3326)
==7283==    by 0x6294A8: get_all_tables(THD*, TABLE_LIST*, Item*) (sql_show.cc:3595)
==7283==    by 0x614C30: get_schema_tables_result(JOIN*, enum_schema_table_state) (sql_show.cc:6673)
==7283==    by 0x60AFA6: JOIN::exec() (sql_select.cc:1875)
==7283==    by 0x60791E: mysql_select(THD*, Item***, TABLE_LIST*, unsigned, List<Item>&, Item*, unsigned, st_order*, st_order*, Item*, st_order*, unsigned long long, select_result*, st_select_lex_unit*, st_select_lex*) (sql_select.cc:2530)
==7283==    by 0x60D078: handle_select(THD*, LEX*, select_result*, unsigned long) (sql_select.cc:290)
==7283==    by 0x5BA784: execute_sqlcom_select(THD*, TABLE_LIST*) (sql_parse.cc:4557)
^ Found warnings in /export/home2/pb2/test/sb_0-2313058-1285285525.3/mysql-5.6.1-m4-linux-x86_64-test/mysql-test/var-ps_row/1/log/mysqld.1.err
ok
--------------------------------------------------------------
--------------------------------------------------------------
[16 Nov 2010 13:00] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/124033

3062 Alfranio Correia	2010-11-16
      Set rpl.rpl_change_master and rpl.rpl_change_master_crash_safe as experimental due to
      BUG#57482.
[23 Nov 2010 21:15] Bugs System
Pushed into mysql-trunk 5.6.1-m5 (revid:alexander.nozdrin@oracle.com-20101123211421-owla1k03goqah2z2) (version source revid:alexander.nozdrin@oracle.com-20101123211421-owla1k03goqah2z2) (merge vers: 5.6.1-m5) (pib:21)
[16 Dec 2010 10:08] Alexander Nozdrin
Closed as the problems reported here were fixed in scope of other bugs.
For instance, Bug#58707.
[16 Dec 2010 13:04] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/127070

3435 Luis Soares	2010-12-16
      BUG#57482: server_uuid fails on PB2
      
      Removed entries from the experimental list.
[17 Dec 2010 12:57] Bugs System
Pushed into mysql-trunk 5.6.1 (revid:georgi.kodinov@oracle.com-20101217125013-y8pb3az32rtbplc9) (version source revid:luis.soares@oracle.com-20101216130453-dc6bjs9ggl54i8os) (merge vers: 5.6.1) (pib:24)
[20 Dec 2010 20:15] Paul Dubois
Changes to test suite. No changelog entry needed.