Bug #56523 Instrumentation regression in myisam/mi_rprev.c
Submitted: 3 Sep 2010 1:12 Modified: 20 Nov 2010 23:01
Reporter: Marc Alff Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: MyISAM storage engine Severity:S2 (Serious)
Version:5.6 OS:Any
Assigned to: Marc Alff
Triage: Triaged: D2 (Serious)

[3 Sep 2010 1:12] Marc Alff
Description:
In myisam/mi_rprev.c, the code was instrumented for the
performance schema, by using the mysql_rwlock_*() apis.

In mysql-next-mr, it seems a backport (Bug#43618: MyISAM&Maria returns wrong results with 'between' on timestamp) caused a regression, and:
- re introduced a use of the old api, rw_unlock(), at line 75
- caused a build warning.

How to repeat:
Read the code, read the build logs, for mysql-next-mr

Suggested fix:
Use mysql_rwlock_unlock().
[3 Sep 2010 1:49] Bugs System
A patch for this bug has been committed. After review, it may
be pushed to the relevant source trees for release in the next
version. You can access the patch from:

  http://lists.mysql.com/commits/117474

3273 Marc Alff	2010-09-02
      Bug#56523 Instrumentation regression in myisam/mi_rprev.c
      
      Re-instrumented the code for the performance schema.
      
      This fix resolves a build warning caused by a merge problem.
[7 Sep 2010 16:43] Christopher Powers
Patch approved.
[7 Sep 2010 19:25] Marc Alff
Pushed into:
- mysql-next-mr-bugfixing

Doc team:
this is a bug that appeared in mysql-next-mr-bugfixing on Aug 16, 2010,
and was fixed in the same place on Sep 7, 2010

This bug never existed in mysql-next-mr.
[2 Oct 2010 18:14] Bugs System
Pushed into mysql-next-mr (revid:alexander.nozdrin@oracle.com-20101002181053-6iotvl26uurcoryp) (version source revid:alexander.nozdrin@oracle.com-20101002180917-h0n62akupm3z20nt) (pib:21)
[13 Nov 2010 16:22] Bugs System
Pushed into mysql-trunk 5.6.99-m5 (revid:alexander.nozdrin@oracle.com-20101113155825-czmva9kg4n31anmu) (version source revid:vasil.dimov@oracle.com-20100629074804-359l9m9gniauxr94) (merge vers: 5.6.99-m4) (pib:21)
[20 Nov 2010 23:01] Paul Dubois
Bug did not appear in any released version. No changelog entry needed.