Bug #56213 per database quota support
Submitted: 24 Aug 2010 8:29 Modified: 24 Aug 2010 9:38
Reporter: Daniël van Eeden Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version: OS:Any
Assigned to:
Tags: quota

[24 Aug 2010 8:29] Daniël van Eeden
Description:
per database quota would be nice for many service providers.

If a service provider grants one or more databases to every customer it should now calculate used data afterwards and bill the customer for the over-quota data. This could be done with the UNIX du utility, but that only works if  innodb_file_per_table is set to 1.

Another posibility is using filesystem quota's on the directories below the datadir, but this is not crossplatform and depends on innodb_file_per_table=1.

With quota support in MySQL this could prevent user from going over quota.

How to repeat:
See Description.

Suggested fix:
Implement quota support.
[24 Aug 2010 9:38] Valerii Kravchuk
This is a duplicate of Bug #21038.