Bug #56163 CTRL-F does not work in query editor and blanks out option in menu
Submitted: 21 Aug 2010 5:52 Modified: 15 Oct 2010 20:41
Reporter: Roel Van de Paar (OCA) Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:5.2.25, 5.2.26 OS:Any
Assigned to: CPU Architecture:Any

[21 Aug 2010 5:52] Roel Van de Paar
Description:
Go into query editor, press CTRL-F. On my machine, no "Find" dialog comes up, and when checking the "edit>find" submenu directly after this "Find and Replace" is grayed out (it is not grayed out when the query editor is just opened).

How to repeat:
^
[22 Aug 2010 21:07] Roel Van de Paar
Verified on 5.2.25 (does the same). Pressing "CTRL-F" lets the query editor loose focus, and therefore the "Find and Replace" gets grayed out (but not "Find"). Clicking inside the query editor enables the "Find and Replace" option again.
[22 Aug 2010 21:16] Roel Van de Paar
CTRL-F never works for me, even when selected from the menu.
[22 Aug 2010 21:34] Jonathon Coombes
Verified under Mac OS X  with Workbench 5.2.26 as well.

When trying Cmd-F (Apple alternative to Ctrl-F) when in the SQL editor, the editor loses focus and no dialog appears to enter the find keyword. Instead of greying out the find options, on the Mac version the Edit menu changes and the Find submenu is not even shown, but instead the Special Characters option. 

Confirmed as well that choosing Find from the Edit->Find menu has the same effect.
[26 Aug 2010 19:54] Orlando Colamatteo
Verified on Windows 7 with Workbench 5.2.26 as well. This is very annoying!!! I can work around it though using Ctrl+H and then clicking onto the "Find" tab.
[2 Sep 2010 14:03] Johannes Taxacher
The reason, why the editor looses focus, is that the quick-Find-textbox in the toolbar is focused, where you can enter your search-text and hit [enter] to start searching - so its actually expected behavior.
[2 Sep 2010 15:37] Orlando Colamatteo
The find box at the top right of the editor obviously causes confusion. I did not know where my cursor went or why my editor window lost focus. For a while I thought my multi-monitor software was hiding the dialog box but pressing Escape did not return focus to the editor window. 

I have opened a feature request bug#56502 to streamline the Find and Replace functionality. Please vote for it if you agree.
[15 Oct 2010 20:41] Johannes Taxacher
closing this report, as its not an actual bug (rather a non-optimal design). report requesting improved interface for find has been opened (see previous comment)